none
the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine RRS feed

  • Question

  • Hi all,

    i have this:

    -windows 7 64 bits

    -visual studio 2013 ultimate

    -office 2013 64 bits

    -AccessDataBaseEngine 64 bits.

    When i run my web application it gives this error:

    "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine".

    There is a post about this error, but it didn´t solve the problem and i was unnable to post this issue there.

    Thanks for all.


    • Edited by Bairos Monday, September 15, 2014 3:08 PM text error
    • Moved by Amanda Zhu Tuesday, September 16, 2014 7:49 AM
    Monday, September 15, 2014 3:07 PM

Answers

  • Fred Bao, as i say in my first post i installed the databaseengine x64, from the microsoft link.

    cnk_gr, then i tried to install the databaseengine 32 bit but it gives the error that "office is for 64 bits".

    i solved my problem by uninstalling the office 2013 x64 and databaseengine 64 and installing office 2010 x86 and databaseengine 32 bit.

    I will still work with you to find a way to conect 64 architectures.

    Thank you all.

    Tuesday, September 16, 2014 9:41 AM

All replies