none
Use SMTP Server to send Email Alerts RRS feed

  • Question

  • Summary:
    I have setup the SMTP server on Windows Server 2012 R2 where my SharePoint 2013 is installed. And will use this to send out email alerts. Unfortunately it's not working. Any suggestions will be appreciated. Thank you!

    More details:
    3 tier SharePoint VM dev server setup (APP, WEB and SQL) with another VM as AD, DC and DNS.

    SMTP server role installed on APP.

    In Central Admin, Outgoing E-Mail Settings, is setup.

    Using Telnet cilent, I have successfully sent out email to my gmail account, so I know the SMTP is working.

    I created a Custom List and setup email alert to alert immediately for any changes made. But no email received.

    Windows Firewall turned off on all machines.

    All users part of Administrators group, in case permissions issue.

    Thanks!

    Friday, February 3, 2017 2:35 AM

All replies

  • You can check if there is any log first.

    It is a big process and the only I can suggest is to check the guide to make sure every step is correct.

    https://technet.microsoft.com/en-us/library/cc263462.aspx


    顺其自然地勇往直前!—Justin Liu

    Friday, February 3, 2017 3:55 AM
  • Run this stsadm command to check if alerts are enabled for your web application:

    Stsadm.exe -o getproperty -url http://SharePoint-web-App-URL -pn alerts-enabled

    This should return <Property Exist="Yes" Value="yes" />

    If you don’t get this, Enable alerts by:     

    stsadm.exe -o setproperty -pn alerts-enabled -pv "true" -url http://SharePoint-web-App-URL

    If its already enabled, try turn off and turn on it back.

         

    Thanks
    Mohit

    Friday, February 3, 2017 6:10 AM
  • I have checked my setup using the guide you suggested and all is well there.

    Thanks!

    Friday, February 3, 2017 9:08 AM
  • Yup. Alerts are enabled!

    Thanks!

    Friday, February 3, 2017 9:09 AM
  • Enable logs in the SMTP server and check the logs for any errors. It might just be a permission issue on the respective directories. Also check ULS logs while trying to send email from SharePoint.

    Thanks
    Mohit

    Friday, February 3, 2017 9:18 AM
  • I have gone over the guide as suggested by Justin and the setup is sound.

    I then attempted to set an email alert in the Custom List.

    So, I go to:

    Custom List > List (tab) > Alert me > Set alert on this list

    At the 'Send Alerts To' it says, I can enter usernames or email addresses.

    1)

    I enter an email address like so:

    'user@gmail.com' and like so: user@gmail.com

    It says, cannot share this with external users

    "user@gmail.com"

    For this it says, couldn't find exact match

    2)

    For AD user profile, I enter a valid email address.

    I then put:

    DOMAIN\username

    This would then supposely send the email alert to that user specified email in their profile.

    I get:

    Error

    Sorry, something went wrong

    You do not have an email address

    Alert has been created successfully but you will not receive notifications until valid email provided in profile

    I know SharePoint periodically syncs with the AD to get the latest user details. But those services must be active.

    I go to Central Admin > Application Management > Service Applications > Manage services on server

    The 'User Profile Service' is Started

    I try to enable the 'User Profile Synchronisation Service' and it wants me to enter a valid user account.

    But no matter what I enter it says: No User Profile Application found. Please create a User Profile Application on the farm.

    The users i tried are Farm Administrators so permissions are correct.

    Any suggestions welcome!

    Friday, February 3, 2017 9:27 AM
  • First you need to go to Central Admin > Application Management > Service Applications > Manage Service Applications. Check if you have created user profile service application or not. If not create it first and then proceed to start user profile synchronization service. More details on same here:

    https://technet.microsoft.com/en-us/library/ff182925.aspx

    https://technet.microsoft.com/en-IN/library/ee721049.aspx

    Once you have done, make sure that users from AD have email address listed in the their AD profile. Then set the email property for mapping with corresponding attribute and then run the import. More details on same here:

    https://sharepointobservations.wordpress.com/2013/07/16/error-you-do-not-have-an-email-address/

    Once its done, it should work fine.


    Thanks
    Mohit

    Friday, February 3, 2017 9:47 AM
  • just to check: did you specify SMTP server in Central administration > System settings > Configure outgoing e-mail settings > Outbound SMTP server?

    Blog - http://sadomovalex.blogspot.com
    Dynamic CAML queries via C# - http://camlex.codeplex.com

    Friday, February 3, 2017 4:00 PM
  • Hi,

    Is any update for your issue?

    Best Regards,

    Lee



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, February 9, 2017 8:47 AM