URL Routing is not working in IIS 7.0 witrh apllication pool asp.net 2.0 Classical Mode RRS feed

  • Question

  • User1550595525 posted

    I have implemented the URL Routing in my projects I have followed the below article: http://www.4guysfromrolla.com/articles/051309-1.aspx#postadlink

    This URL Routing Demo works fine in my "IIS 7.0 with application pool asp.net 2.0 Integrated Mode"

    but not works(gives 404 error) when I have set it as "IIS 7.0 with application pool asp.net 2.0 Classical Mode"

    i need a configuration for IIS 7.0 with application pool configured as classic mode in asp.net 2.0 .

    Please specify your configuration for above project to work(or routing to work)


    Saturday, September 10, 2011 7:23 AM


  • User1622957740 posted

    Integrated mode can dynamically re-route a request via a web.config option

    		<modules runAllManagedModulesForAllRequests="true">

    which ensures that all requests are routed to ASP.NET including extensionless Urls used for typical routing apps.

    Classic mode doesn't use that switch, so you need a wildcard script map.

    There's more info here:


    Even though that message talks about MVC the same applies for Web forms.

    Now, all that said - why do you need to use classic mode? Especially if you're planning on using routing integrated mode is a much better and more efficient choice...

    +++ Rick ---

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 20, 2011 7:16 PM