none
"Remote Desktop Service start failed" error on Hyper-V VM using RemoteFX RRS feed

  • Question

  • Hi. Trying to test RemoteFX feature in Win 2008 R2 SP1 RC on single machine with Core i7 and Quadro 3800. Whenever the RemoteFX 3D virtual video card is added to VM (running Windows 7 with SP1 RC applied), I'm then unable to connect with Remote Desktop client running on host. Removing the RemoteFX virtual hardware, I'm then able to remote desktop into VM, and in the event log at Applications and Services Logs/Microsoft/Windows/TerminalServices-LocalSessionManager/Operational has error events with the message Remote Desktop Service start failed. The relevant status code was 0x800706b5.

    Does anyone know what error code 0x800706b5 in this context means, or knows reasons why the Remote Desktop Service would fail to start in the Win7 VM when the RemoteFX 3D virtual hardware is added?

    Kind regards,
    -Paul

    Monday, December 6, 2010 4:11 PM

Answers

  • Hello all,

     

    i got exactly same problem as you phestermcs. (error 0x800706b5)

     

    VM is a fresh install of Win 7 x64 Enterprise SP1. anyways i found the solutions. it's because rules "RDS Remote FX" is not allowed in the VM's firewall.

     

    A new Windows Firewall rule is added for RemoteFX. If you perform a new installation and enable Remote Desktop by using the System properties sheet, the rule is enabled automatically.

    You must enable the RemoteFX Windows Firewall rule manually if you do either of the following:

    • Enable Remote Desktop by using the netsh command or the Windows Firewall APIs.
    • Upgrade to Windows 7 with SP1 on a virtual desktop that already had Remote Desktop enabled.

    It solved the prob for me!

     

     

    Regards,

    • Marked as answer by phestermcs Friday, March 11, 2011 2:06 PM
    Friday, March 11, 2011 12:22 PM

All replies

  • same issue

    With remotefx device installed, according to the system logs, it seems like it fails to create self signed certificate for Terminal Services.

    This situation only seem to happen if you installed updates on your Win7SP1.  If you do a fresh install, then install the SP1 without doing updates first, your remote desktop will work, and then you enable remotefx and it will install and remote desktop also works. Everythign is fine. You can now install any windows updates you like.

    If you shutdown remove the remotefx device, boot it up and work on it normally, then reinstall the remotefx device, your terminal services will now fail.

    If you do a fresh install, install all the normal windows7 updates, then install SP1 RC, and then add the remotefx device, your terminal services will once again fail.

    I haven't thoroughly tested all these scenarios as it takes a while to keep installing win7, but it seems to be the case.   Since you cannot see what is going on during bootup, and you cannot RDP with the remotefx device installed, it is hard to tell what is going on.

    From what I can gather your RDP will fail if you run updates before adding the remotefx device to your VM.

    Wednesday, December 22, 2010 10:50 PM
  • I am seeing this exact error on a non Hyper-V (desktop) install, just my personal Win7 Ultimate x64 SP1.  According to my research, the  0x800706b5 error indicates "RPC_S_UNKNOWN_IF" but beyond that I don't know if that refers to a physical (e.g. ethernet interface) or a programmatic (e.g. some sort of API) interface.  Does anyone know how to correct this error without completely reinstalling the OS?
    Wednesday, March 2, 2011 2:05 PM
  • Hello all,

     

    i got exactly same problem as you phestermcs. (error 0x800706b5)

     

    VM is a fresh install of Win 7 x64 Enterprise SP1. anyways i found the solutions. it's because rules "RDS Remote FX" is not allowed in the VM's firewall.

     

    A new Windows Firewall rule is added for RemoteFX. If you perform a new installation and enable Remote Desktop by using the System properties sheet, the rule is enabled automatically.

    You must enable the RemoteFX Windows Firewall rule manually if you do either of the following:

    • Enable Remote Desktop by using the netsh command or the Windows Firewall APIs.
    • Upgrade to Windows 7 with SP1 on a virtual desktop that already had Remote Desktop enabled.

    It solved the prob for me!

     

     

    Regards,

    • Marked as answer by phestermcs Friday, March 11, 2011 2:06 PM
    Friday, March 11, 2011 12:22 PM