none
Is Oracle Client to 10.2.0.5 compatible with BizTalk Server 2006 R2 RRS feed

  • Question

  • I have BizTalk Server 2006 R2 on Windows 2003 Server R2 in production environment. Oracle Client 10.2.0.1.0 is installed for DB connectivity. For certain reasons, I have to upgrade the Oracle Client to version 10.2.0.5.

    Is Oracle Client to 10.2.0.5 compatible with BizTalk Server 2006 R2 (any authentic link?)?

    Tuesday, September 13, 2011 4:25 PM

Answers

  • I'll give you the short answer is yes, it should work, though the Oracle DBA ripping hair out of his head seems to dictate otherwise.  I would suggest you get ahold of Oracle on thier driver support, they are rather picky on what they will say works and not.

    http://download.oracle.com/docs/cd/B19306_01/relnotes.102/b15680/toc.htm

    On the side note, I have seen other articles of BizTalk devs using 10.2.0.5, and having validation problems, somthing with the Oracle client that they were hoping to see Oracle release a patch on.


    :P Advice offered, If you need more help it is advised to seek the council and advice of paid professionals. The answer is always 42, or reboot.
    Tuesday, September 13, 2011 5:38 PM
  • Hi Muhammed,

    If you use/install BizTalk Adapter Pack 2.0 than there is support for Oracle 9.2; Is that version you are running?

  • Supported server versions: Oracle database version 11.1, Oracle database version 10.2, Oracle database version 10.1, Oracle database version 9.2

    Supported client versions: Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7

    Reference see installation guide Adapter Pack 2.0. For Adapter Pack 1.0:

    Supported server versions: Oracle 9.2.0.2, Oracle 10.1.0.2.0, Oracle 10.2.0.1.0

    Supported client versions: Oracle client version 10.2.0.3.

    For reference see installation guide Adapter Pack 1.0.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server 2010
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


  • BizTalk
Wednesday, September 14, 2011 6:39 AM
Moderator

All replies

  • I'll give you the short answer is yes, it should work, though the Oracle DBA ripping hair out of his head seems to dictate otherwise.  I would suggest you get ahold of Oracle on thier driver support, they are rather picky on what they will say works and not.

    http://download.oracle.com/docs/cd/B19306_01/relnotes.102/b15680/toc.htm

    On the side note, I have seen other articles of BizTalk devs using 10.2.0.5, and having validation problems, somthing with the Oracle client that they were hoping to see Oracle release a patch on.


    :P Advice offered, If you need more help it is advised to seek the council and advice of paid professionals. The answer is always 42, or reboot.
    Tuesday, September 13, 2011 5:38 PM
  • Thanks Jason for your reply... but this article doesn't address my question.

    Let me provide more information: for all my BizTalk projects, I use "ODBC drivers for Oralce 9"... AND for all my Helper class libraries, I use the System.Data.OracleClient namespace for connectivity with DB.

    I believe, after installing Oracle Client 10.2.0.5, BizTalk project will carry on using "ODBC drivers Oracle 9"... AND Helper class libraries will refer to latest System.Data.OracleClient namespace libray from .NET Framework.

    BUT I want to confirm it before proceed. Any comments?


    Tuesday, September 13, 2011 7:49 PM
  • Your best bet will be to try this is in a development environment.
    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Wednesday, September 14, 2011 5:30 AM
  • Hi Muhammed,

    If you use/install BizTalk Adapter Pack 2.0 than there is support for Oracle 9.2; Is that version you are running?

  • Supported server versions: Oracle database version 11.1, Oracle database version 10.2, Oracle database version 10.1, Oracle database version 9.2

    Supported client versions: Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7

    Reference see installation guide Adapter Pack 2.0. For Adapter Pack 1.0:

    Supported server versions: Oracle 9.2.0.2, Oracle 10.1.0.2.0, Oracle 10.2.0.1.0

    Supported client versions: Oracle client version 10.2.0.3.

    For reference see installation guide Adapter Pack 1.0.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server 2010
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


  • BizTalk
Wednesday, September 14, 2011 6:39 AM
Moderator