none
Problem Setting Reporting Services Parameter Properties RRS feed

  • Question

  • I'm trying to write a Reporting Services report that has several parameters.  I've added 1 parameter and declared it as internal (I've used this in several other reports and it always works).  Then I add another parameter that is not internal -- for this one I need to have multi-values and blanks allowed, so I click the appropriate check boxes.  After setting the second parameter up, if I return to the first I see that this parameter is no longer set to be internal.  If I reset it to internal and then examine the second parameter, I see that it has been set to internal as well, which wasn't what I wanted.  If I then uncheck the internal box, the internal box in the first parameter gets unchecked as well.  This is making me nuts.  I've written quite a few reports (many of them using that identical internal parameter), and this hasn't happened before.  I've tried changing the order of the parameters in the parameter list and that doesn't help.  I've tried altering the rdl directly, but that hasn't been successful either.  Has anybody come across anything like this?  Thanks.

     

    Friday, August 3, 2007 11:28 PM