locked
Data Migration Assistant v3.3 running against SQL Server 2017 (to move to Azure Database) RRS feed

  • Question

  • Hi,

    I'm getting an error with the DMA v3.3 running against 2017. The error is:

    "The database 'xxxxx' from server 'yyyyy' cannot be assessed because its version is greater than the selected target."


    I've tried changing the compatibility level of the database being assessed from 140, to 130 and even 120. Still the same error. Has anyone else seen this? I've emailed dmafeedback@microsoft.com as requested. 


    Any help appreciated.



    Wednesday, January 3, 2018 11:42 AM

All replies

  • You are trying to assess a database from a later version (say, 2017) with a target of a prior version (2016 or older). 

    The DMA will give back this error, saying it cannot evaluate the database. if you want to do a compatibility check for a database against a previous version, use Visual Studio and SQL Server Data Tools instead.

    HTH

    • Proposed as answer by Teige Gao Thursday, January 4, 2018 2:35 AM
    Wednesday, January 3, 2018 5:56 PM
  • Hi,

    No I wasn't. I was checking SQL Server 2017 - Azure Database. This gave me the error.

    However, I later realized that what I wanted was to asses tables suitable for Stretch - and to do that in the DMA you need to choose SQL Server (2017) - SQL Server (2017) and click suggest new features.

    So it's not a bug as such, it was user error on my part.

    Monday, January 8, 2018 8:58 AM
  • Hi Phil,

    Could you please tell us if you have solved this problem? If it is, could you please mark your own reply as Answered?

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 10, 2018 8:22 AM