none
[UWP]Visual Studio 2015 Uses Debug Mode Even When Release Is Selected

    Question

  • I am preparing to submit my Windows Store app. However, even though I have Release selected in the toolbar at the top of the screen, Visual Studio 2015 is running the app in Debug mode. This is preventing me from getting good screenshots because the little black boxes are displayed. Why is Visual Studio 2015 running in Debug mode when I have Release mode selected in the toolbar, and what can I do to fix it? Thanks.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Saturday, October 29, 2016 4:35 PM

Answers

  • Hi Nathan,

    Thank you for your update and it looks like we have some misunderstand about the Output> Show output from and the option ‘Debug’, the field ‘Show output from’ displays one or more output panes to view. Several panes of information might be available, depending on which tools in the IDE have used the Output window to deliver messages to the user, please check Output Window. The Debug means display the debug information under the Output window, not relate to the solution is under Debug/Release mode.

    >> Here is a screenshot from the Simulator (I have cropped it since most of it is irrelevant) that leads me to believe that it is in Debug mode:

    I found those 4 icons appear no matter your solution is under Debug/Release mode, so it cannot mean that your solution is debug mode when you already chose the release mode.

    To check your solution is Debug/Release mode, you can try to right click the project/solution-Properties and click the Build/Debug tab, then find the Output path and open it, then manually delete the debug/release folders like the following, and choose the debug or release in the upper toolbar, then build the project, see if the debug or release folder will be created or not.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 07, 2016 9:01 AM
    Moderator

All replies

  • Hi Nathan,

    Welcome to the MSDN forum.

    >> However, even though I have Release selected in the toolbar at the top of the screen, Visual Studio 2015 is running the app in Debug mode.

    Could you please create a new UWP project and select the Release, if it works fine, that means this issue is related to your current UWP project. Maybe some App features cannot be running under the Release mode or other reasons…

    If the same issue persists, please try to create another different project template, see if this issue persists for other different template or not, it can help us to confirm this issue is related to VS itself or not.

    BTW, could you please share us with some screenshot or how did you confirm the current application is running under the Debug mode even if you already chose the Release mode?

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, October 31, 2016 8:54 AM
    Moderator
  • I tried building some of my previous apps in the same solution (I have literally not touched these apps since I built and submitted them), and interestingly they did the same thing even though I was able to build them in Release mode before. This is leading me to believe that the problem is either with the Solution or Visual Studio 2015. Any ideas? Thanks.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Monday, October 31, 2016 5:15 PM
  • Hi Nathan,

    Thank you for your update.

    >> This is leading me to believe that the problem is either with the Solution or Visual Studio 2015.

    To exclude this problem is related to the Solution or not, please try to create a new Solution, and if the same issue not happen, that means this issue is related to your current solution. If not, it looks like this problem more related to VS itself. Please upload your solution to https://onedrive.live.com/ and share the link in here, we will try to test it on our local computer.

    BTW, could you please share the screenshot that you can found the solution is running in the Debug mode, even if you already selected the Release on the top toolbar.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 01, 2016 8:19 AM
    Moderator
  • I tried it in a new solution, same problem. Here is the build output when I try to build it:

    1>------ Build started: Project: UniversalAppExtras, Configuration: Release x86 ------
    1>  UniversalAppExtras -> C:\Users\Nathan\Documents\Visual Studio 2015\Projects\UniversalAppExtras\bin\x86\UniversalAppExtras.dll
    2>------ Build started: Project: TicketToRideGreatLakes, Configuration: Release x86 ------
    2>  TicketToRideGreatLakes -> C:\Windows10_Release\TicketToRideGreatLakes\bin\x86\TicketToRideGreatLakes.exe
    3>------ Deploy started: Project: TicketToRideGreatLakes, Configuration: Release x86 ------
    3>Updating the layout...
    3>Deployment complete (0:00:00.057). Full package name: "55114NathanSokalski.TicketToRide-RailsSailsGreatLa_1.1.0.0_x86__xn6m6fj72n7zr"
    ========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    ========== Deploy: 1 succeeded, 0 failed, 0 skipped ==========

    Notice that both projects say "Configuration: Release x86". Here is a screenshot from the Simulator (I have cropped it since most of it is irrelevant) that leads me to believe that it is in Debug mode:

    Also, Visual Studio 2015 opens the Output window with Debug selected for "Show output from". And like I said, the same thing happens even in a new solution. Does this mean something got screwed up in Visual Studio 2015's settings? Thanks.


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Tuesday, November 01, 2016 7:45 PM
  • Hi Nathan,

    Refer to your description, I have tried to build a new UWP project with the Release/Debug mode and I found the filed “Show output from:” always selected the “Build” as below, then click the dropdown list of this filed, there is no ‘Debug’ value like you said. It looks like this issue is more related to your VS 2015.

    >> Does this mean something got screwed up in Visual Studio 2015's settings?

    Please have a try with the following to tourbleshot this issue:

    1. Restore the default settings, please go to Tools-Import and Export Settings… and select ‘Reset all settings’, then save your current settings, then click ‘Finish’ button to reset the customized setting to the default, it can help us to excludes the customized setting caused this issue.
    2. Navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run the following commands. After each command, please check this issue is disappear or not.

    devenv /resetuserdata: clear the old user data

    devenv /safemode: run the VS as safe, if it works fine that means the installed extensions may be corrupted the VS, please go to Tool—Extensions and Updates… and remove all installed extensions one by one to find the culprit.

    Meanwhile, you can also try to repair VS 2015 through Control Panel—Programs and Features and right click the VS 2015 item, select Change-Repair, after that, please create a new UWP project and check this problem again.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 02, 2016 9:11 AM
    Moderator
  • I have reinstalled Windows 10 Pro, redownloaded & reinstalled Visual Studio 2015 Community, and created a new Solution. Still same problem. I don't know how anything can possibly be getting changed, but something is causing a problem. Have there been any recent updates to Visual Studio 2015 that could be causing this (maybe, even though it is not selected as my Target version, when the Windows 10 Anniversary Edition was added)? Is it possible that something in Windows 10 itself is causing the problem? I don't even know where to start anymore.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Thursday, November 03, 2016 8:00 PM
  • Hi Nathan,

    After you reinstalled OS and VS community 2015, does the following issue still occur?

    >>Also, Visual Studio 2015 opens the Output window with Debug selected for "Show output from".

    My VS is VS enterprise 2015 with update 3 and I found there is no 'Debug' in the dropdown list for "Show output from" as below:

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 04, 2016 9:10 AM
    Moderator
  • Yes, it does.


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Friday, November 04, 2016 3:22 PM
  • Hi Nathan,

    Thank you for your update and it looks like we have some misunderstand about the Output> Show output from and the option ‘Debug’, the field ‘Show output from’ displays one or more output panes to view. Several panes of information might be available, depending on which tools in the IDE have used the Output window to deliver messages to the user, please check Output Window. The Debug means display the debug information under the Output window, not relate to the solution is under Debug/Release mode.

    >> Here is a screenshot from the Simulator (I have cropped it since most of it is irrelevant) that leads me to believe that it is in Debug mode:

    I found those 4 icons appear no matter your solution is under Debug/Release mode, so it cannot mean that your solution is debug mode when you already chose the release mode.

    To check your solution is Debug/Release mode, you can try to right click the project/solution-Properties and click the Build/Debug tab, then find the Output path and open it, then manually delete the debug/release folders like the following, and choose the debug or release in the upper toolbar, then build the project, see if the debug or release folder will be created or not.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 07, 2016 9:01 AM
    Moderator
  • Thank you for that information. The Release folder is created, so I guess that means it is using Release mode. However, that still leaves my problem of the 4 icons. These have never appeared during Release mode before, and I obviously can't have them there for my screenshots (and definitely not when the app is run for real). Is there a way to specify when or under which configurations they should be visible? Thanks.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Monday, November 07, 2016 6:03 PM
  • I think I found the answer to that part at:

    http://stackoverflow.com/questions/36618494/disable-visual-studio-2015-extra-debug-option

    Thanks again for your help!


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Monday, November 07, 2016 6:16 PM
  • Hi Nathan,

    I'm so glad to hear that your issue is solved and thank you for your sharing.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 08, 2016 1:22 AM
    Moderator