none
Visual Studio Source Control Explorer File Associations, can't get a PDF document to open in an external viewer

    Question

  • When I'm in the source control explorer, and I have a PDF document:

    SCE PDF Doc

    When I right click and "View" or Double Click:

    ContextMenu

    The document opens in Visual Studio as a text document.  

    PDFSource

    There's no easily found option to change the association in SCE by document types.  The document opens fine in Windows Explorer in a PDF viewer.

    This file isn't necessarily in a Solution, it's just in Source Control as a project document.

    How can I get VS SCE to open this with a suitable viewer instead of as text?


    Thursday, July 07, 2016 6:33 PM

Answers

  • Hi Clinton Pierce,

    As far as I know, Visual Studio is not support PDF file read by default. I have tried open a PDF file directly with Visual Studio in local, I get the same result with you.

    Please try use a PDF viewer which installed on your machine to open the PDF file in Visual Studio. The detailed steps are:

    1. Right-click the PDF file which is include in your solution.
    2. Choose "Open With..." to open the windows.
    3. Click the "Add" button to add the PDF viewer that on your machine.
    4. Choose this PDF viewer to open the PDF file in Visual Studio.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, July 11, 2016 6:03 AM
    Moderator