locked
Maximum Database Size Limit RRS feed

  • Question

  • We have hit the following error...

    Failed to create the object with name 'cep:/Server/Application/Matrikon.Suite.Cep/QueryTemplate/ContinuousWindowsProcessing-Inputs=1-6380-LimitThreshold=0'.-->The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ]
    Matrikon.Suite.Cep.Exceptions.InvalidQueryConfigurationException: Failed to create the object with name 'cep:/Server/Application/Matrikon.Suite.Cep/QueryTemplate/ContinuousWindowsProcessing-Inputs=1-6380-LimitThreshold=0'.-->The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ] ---> Microsoft.ComplexEventProcessing.InvalidDefinitionException: Failed to create the object with name 'cep:/Server/Application/Matrikon.Suite.Cep/QueryTemplate/ContinuousWindowsProcessing-Inputs=1-6380-LimitThreshold=0'.-->The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ] ---> Microsoft.ComplexEventProcessing.Metadata.MetadataException: Failed to create the object with name 'cep:/Server/Application/Matrikon.Suite.Cep/QueryTemplate/ContinuousWindowsProcessing-Inputs=1-6380-LimitThreshold=0'. ---> The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ]

    Can this limit be configured in StreamInsight?

    Nathan

    Wednesday, September 1, 2010 2:21 PM

Answers

  • Nathan,

    We'll allow the database to grow past its default limit in our next update. For the moment, the limit is 256MB on desktop and 128MB on devices, and as you could see it's a connection setting so the product code needs to be changed. Even if we expose a knob, the SqlCe database has an upper limit of 4GB. Do you think you will hit that too?

    Regards,


    Ciprian Gerea SDE, MS StreamInsight Team Disclaimer: This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Nathan Nilson Monday, September 13, 2010 2:56 PM
    Thursday, September 9, 2010 3:48 PM

All replies

  • Hi Nathon

    I cannot really understand what u where doing. Can you please tell us something more about what where u doing.

    • One more question. Dit you generated New Thread for every differant Input and output in Your Input and Output Adapter.
    • Or is it something like you did not generate any CTI Event which made you reach this limit ??

    Thanks Looking forward to your response.

     


    Thanks Priyank Piyush
    • Proposed as answer by Priyank Piyush Wednesday, September 8, 2010 7:12 AM
    Thursday, September 2, 2010 6:52 AM
  • Hi Nathan,

    The error message seems to suggest that you have exhausted the space on the metadata database. Can you check if your code leaks objects i.e. creates them in a loop without deleting the ones you no longer need? Another possibility would be that you create a reasonable number of queries but they are very large so they eat up the space.

    A possible workaround would be to delete the unneeded queries, query templates, adapters and event types. That would free up space on the metadata database.


    Ciprian Gerea SDE, MS StreamInsight Team Disclaimer: This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 7, 2010 5:06 PM
  • Sorry, I was kinda lazy when I entered the posting originally.  Lets start over. :)

    I am creating a few queries (more than 10,000, at least 15 inputs each, could easily grow to more than 50,000 queries).  The IMPORTANT part of the error message is...

    Failed to create the object with name 'cep:/Server/Application/Matrikon.Suite.Cep/QueryTemplate/ContinuousWindowsProcessing-Inputs=1-6380-LimitThreshold=0'.-->The database file is larger than the configured maximum database size. This setting takes effect on the first concurrent database connection only. [ Required Max Database Size (in MB; 0 if unknown) = 257 ]

     

    The database is larger than the maximum configured size?  Now I know that you can use the connection string in SQLCE to define the maximum database size (which defaults to 128 MB I think), but I cannot see any way to do this to the internal SQLCE database used by Stream Insight for preserving queries.  There is no connection string and the SqlCeMetadataProviderConfiguration class (A parameter taken by Server.Create()) provided by Stream Insight does not expose any database size limit configuration options. 

    Can the database size limit be configures in SI?  Running fewer queries would only be a LAST RESORT workaround to my issue.

    Nathan

    Wednesday, September 8, 2010 3:31 PM
  • Nathan,

    We'll allow the database to grow past its default limit in our next update. For the moment, the limit is 256MB on desktop and 128MB on devices, and as you could see it's a connection setting so the product code needs to be changed. Even if we expose a knob, the SqlCe database has an upper limit of 4GB. Do you think you will hit that too?

    Regards,


    Ciprian Gerea SDE, MS StreamInsight Team Disclaimer: This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Nathan Nilson Monday, September 13, 2010 2:56 PM
    Thursday, September 9, 2010 3:48 PM
  • I don't think there is a great risk that we will hit the 4GB limit.  Thanx

    Nathan

    Monday, September 13, 2010 2:56 PM
  • Ciprian,

    Our team has taken over from Nathan's on the integration of StreamInsight into our product.  We've tested with version 1.1 of StreamInsight and are still hitting the limit at 256MB.  Are there still plans on increasing the database size defaults in StreamInsight, or, optionally, adding hooks so that we can configure the database size ourselves?  If so, when is the expected next release of StreamInsight that will address this issue?

    Regards,

    David Babowal

    Wednesday, February 16, 2011 6:04 PM
  • Hi David,

    Can you try meanwhile to scale out your CEP system? That is, to have 2 or more StreamInsight instances (on the same machine, or not) and separate your queries in multiple packages, while using the same input stream. This way, the hardcoded limit could be avoided.

    Thanks,

     


    Marius
    Thursday, February 24, 2011 4:39 PM