locked
Local Development Issue RRS feed

  • Question

  • User-1197227883 posted

    Hi there


    Security Update for Microsoft .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008, Windows Server 2008 R2 for x64-based Systems (KB2416472)
    Installation date: ‎08/‎10/‎2010 18:14
    Installation status: Successful
    Update type: Important
    A security issue has been identified that could allow an attacker to compromise your Windows-based system that is running the Microsoft .NET Framework and gain access to information. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.
    More information: 
    http://go.microsoft.com/fwlink/?LinkId=202374
    Help and Support: 
    http://support.microsoft.com



    Since this security patch came out (KB2416471 and KB2416471) I have released it onto 2 development environments as follows:


    Windows 7 Professional 32-bit

    Visual Studio 2010

    Visual Studio 2008

    SQL Server 2008

    IIS 7


    And


    Windows 7 Professional 64-bit

    Visual Studio 2010

    Visual Studio 2008

    SQL Server 2008

    IIS 7


    The web applications are using .net 3.5 (VS2008).


    I have configured the IIS service to work with bindings for the local machine with are set in the hosts file.  I have used the default web application and the created web applications using the bindings.  The problem I have is that since this release the pages will not load correctly, usually stalling for long enough to get "Internet Explorer cannot display the page".  The server releases have gone through fine, as far as I am aware there are no problems (so far... ;))


    Removing the security update fixes the problem immediately on the development environments.  As it is the same on both machines I am surprised I haven't found the same problem from other users.


    Any help would gratefully be appreciated.


    Thanks


    Mike

    Saturday, October 9, 2010 9:32 AM

All replies

  • User-1197227883 posted

    Hi Everyone


    Is there anything I can add to the post above to get any help on this issue (or am I unfortunately the only person suffering from this)???


    The main issue at the moment is that I have to get everyone in the development team to remember to remove the updates, configure their windows update settings, and also do some registry hacking to prevent these updates to be installed on a shut down.  Then, in order to prevent this issue occurring, we need to check our updates every week and deselect KB2416471 and KB2416472.  


    If no one else has had this problem when hosting a development website through IIS 7 locally, is there any further info I can gather to demonstrate it in this environment?


    Thanks


    Mike

    Monday, December 13, 2010 5:06 AM
  • User1618479829 posted

    Can you tell me how you configured IIS 7 ( using apphost.config ?)

    Friday, April 1, 2011 4:12 PM
  • User-1359474226 posted

    Is the issue because of both the KB upgrade or it is because of one of them.

    Please check this link.

    http://weblogs.asp.net/scottgu/archive/2010/09/28/asp-net-security-update-now-available.aspx

     

    Monday, May 16, 2011 1:32 AM