none
Not able to view managed code infopath form via browser

    Question

  • I have a managed code browser enabled  infopath form  that is uploaded into a form library. When i tried to view via browser it always launches infopath to display the content. I enabled browser display in central admin & site collection . still no success

    Following is my URL

    http://moon/sites/Other/_layouts/FormServer.aspx?XsnLocation=/sites/Other/Assessment/Assessmentp.xsn&Source=http://moon/sites/Other/Assessment/Forms/AllItems.aspx&OpenIn=Browser&DefaultItemOpen=1


    chakrapani ramachandran
    Wednesday, January 26, 2011 3:19 PM

Answers

  • Chack,

     

    You've followed the right steps. When I mentioned don't publish the form using the designer I meant don't publish it directly to SharePoint Server library. You had to upload it using central admin the way you did. Though you have to publish it to a network location first !

    Try to go to the Manage Form Templates page, then click on the item menu -that's the little arrow to the right of the forms name bringing the context menu of the item-, and choose "edit in browser". What happens this way?

    • Marked as answer by Wayne Fan Thursday, February 03, 2011 2:17 AM
    Thursday, January 27, 2011 6:51 AM
  • By the way. This may seem silly but in ShaePoint almost everything is worth a shot.

    If my first suggestion didn't work, try to remove the code you used in the form and strip it to its basic functionality. If the forms starts to show in the browser gradually add the code step by step. In earlier versions of Forms services almost any exception in the form would generated the notorious "Form has been closed" message. Also try to look up the correlation ID in SP logs. You'll most probably not find anything, but it's worth a shot.

    • Marked as answer by Wayne Fan Thursday, February 03, 2011 2:17 AM
    Thursday, January 27, 2011 6:55 AM

All replies

  • go to the form library and select the Relink view.

    what is the template URL for your uploaded form?

    If the template URL isn't in SharePoint, click Relink, and try again.


    jliu - johnliu.net - sharepointgurus.net
    Wednesday, January 26, 2011 3:31 PM
  • Relink didn't work

    template url http://moon/sites/Other/Assessment/Assessmentp.xsn 

    If i try to edit the template i am getting the following error

     

    This form template is not currently browser enabled.

    Correlation ID:a57384a4-176c-4b98-ac9d-5ffa1e49979b

    In Log

    Reporting Cannot Render in Browser for:Xsn Url=/sites/Other/Assessment/Assessmentp.xsn, SolutionInfo.Name= urn:schemas-microsoft-com:office:infopath:Assessmentp:-myXSD-2011-01-25T07-32-13, DeploymentMode=None. Parameters: OpenIn=Browser, RequestType=GET, OpenInFromDefaultItemOpen=None, RequestUrl=/sites/Other/_layouts/formserver.aspx?XsnLocation=%2Fsites%2FOther%2FAssessment%2FAssessmentp%2Exsn&OpenIn=Browser&Source=http%3A%2F%2Fmoon%2Fsites%2FOther%2FAssessment%2FForms%2FAllItems%2Easpx ed8d7604-6e4f-494f-8e8c-deb68f63af6f

     


    chakrapani ramachandran
    Wednesday, January 26, 2011 5:16 PM
  • check compatibility and see if you are using web form.

    run the design checker and see the warnings and errors.  it's possible that you are using features that prevents the form from being rendered as a web form


    jliu - johnliu.net - sharepointgurus.net
    Wednesday, January 26, 2011 10:02 PM
  • How did you deploy the form? Did you upload it using Central admin? The error log says Deployment mode is none!!

    • You should have administrator privilege and log in to Central Admin and upload your form using the Manage Form Templates page.
    • Then activate this form to a certain site collection which will deploy it to FormServerTemplates library in the root site.
    • Then define your form library content type's document template.

    There are several tutorials on the web on how to do this. Don't use the publish feature of InfoPath designer. If you still need help just tell me.

    Regards

    Wednesday, January 26, 2011 10:11 PM
  • Nader,

    I am a domain admin in that machine

    I published my form through infopath designer

    uploaded the  form using the Manage Form Templates page.

    activated the form to a certain site collection which will deploy it to FormServerTemplates library in the root site.

    defined a  form library content type's document template.

     

    "Don't use the publish feature of InfoPath designer. "

    How do we publish a form without  infopath designer

    Thanks


    chakrapani ramachandran
    Thursday, January 27, 2011 1:09 AM
  • I've published InfoPath 2010 forms to SP2010 Forms Library fine without going through Central Admin.

    But my Template Url looks like this:

    http://server/FormsLibrary/Forms/template.xsn

    I'd check:

    1. Backstage | Form Options | Compatibility | Web Browser Forms
    2. Backstage | Design Checker -> verify no errors or warnings, my suspicions are currently that you have errors preventing you from running the form via forms services, and thus it's defaulting back to the Rich client Filler.
    If the design checker looks fine, then go through the publish steps again.

    Just an additional note - if you are using code behind with InfoPath publish to Forms Library, you will need to have Sandbox Solutions service running on that server.  Which handles your code behind.

     


    jliu - johnliu.net - sharepointgurus.net
    Thursday, January 27, 2011 3:08 AM
  • John,

     

    "Compatibility | Web Browser Forms

    verify no errors or warnings, my suspicions are currently that you have errors preventing you from running the form via forms services, and thus it's defaulting back to the Rich client Filler.

    "

    I checked the above before deploying the form in central admin.

    Do you have any tutorial i can follow?

    In my form i am accessing sharepoint list using sharepoint object model API


    chakrapani ramachandran
    Thursday, January 27, 2011 4:16 AM
  • Chack,

     

    You've followed the right steps. When I mentioned don't publish the form using the designer I meant don't publish it directly to SharePoint Server library. You had to upload it using central admin the way you did. Though you have to publish it to a network location first !

    Try to go to the Manage Form Templates page, then click on the item menu -that's the little arrow to the right of the forms name bringing the context menu of the item-, and choose "edit in browser". What happens this way?

    • Marked as answer by Wayne Fan Thursday, February 03, 2011 2:17 AM
    Thursday, January 27, 2011 6:51 AM
  • By the way. This may seem silly but in ShaePoint almost everything is worth a shot.

    If my first suggestion didn't work, try to remove the code you used in the form and strip it to its basic functionality. If the forms starts to show in the browser gradually add the code step by step. In earlier versions of Forms services almost any exception in the form would generated the notorious "Form has been closed" message. Also try to look up the correlation ID in SP logs. You'll most probably not find anything, but it's worth a shot.

    • Marked as answer by Wayne Fan Thursday, February 03, 2011 2:17 AM
    Thursday, January 27, 2011 6:55 AM
  • One key element needs emphasising: the network location to which the form is published *must* be accessible to the account deploying the solution and activating the feature. 

    It seems a simple point but with developers usually building WSP packages on individual virtual development environments then it’s quite likely that the form publish location is set to a local drive or network share within limited access.  If this location is inaccessible to the account responsible for deploying to integrated development, test or production environments then the "Reporting Cannot Render in Browser for:Xsn" error message, as shown above, will be observed for end users attempting to access the form in the browser.

    Friday, July 06, 2012 4:40 AM