locked
Unable to design using Blend

    Question

  • I have a big HTML5+Javascript application ready for Windows 8. Application is working perfectly when I run it from 'Visual Studio Express 2012 RC for Windows 8'. But when I open it in Blend it does not show any errors, but does not run any Javascript at all.

    I just see the default.html page without any JS executed.

    How can I know what is wrong and where the Blend is failing. This problem is coming only for my big application where the amount of JS code is more than 1.5MB.

    Blend is working fine for other sample applications and for small apps.

    Monday, August 6, 2012 5:46 AM

All replies

  • Hi Rajesh,

    the standard view in Blend is the design view. Not quite sure how many JS is being executed there. You can switch the "interactive mode" (small button next to the refresh button on top of the main view).


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    Microsoft Most Valuable Professional for BizTalk Server
    http://www.appfabric.de

    Monday, August 6, 2012 12:36 PM
  • I am aware of the Design and Interactive modes. No, app is not working in any mode. What I see is what ever I put in the default.html file. No JS is being executed.
    Monday, August 6, 2012 1:10 PM
  • Is it possible for you to share your repro app with the development team? If so, please email it to me in a zip file to first.last@microsoft.com (using my name) so we can attempt to repro the problem on our end.
    Monday, August 6, 2012 2:27 PM
  • Sure I can send, but my JS is already obfuscated(by GWT) is it okey?

    The app will launch and work fine in Visual Studio but not in Blend.

    Monday, August 6, 2012 2:49 PM
  • Should be no problem, I'll pass it along to the rest of the team to see if they can repro the problem with your project.
    Monday, August 6, 2012 2:50 PM
  • I have sent the files. You can notice on the first project that line numbers for Javascript errors are not visible. But in 2nd project there are no errors, but still not working.
    Monday, August 6, 2012 4:55 PM
  • Any update on this problem? or a temporary workaround?
    Thursday, August 16, 2012 9:15 AM