none
Performance Profiler won't launch program (VS 2015)

    Question

  • I'm having a problem where I am unable to launch any Win32/C++ program with any of the profiler tools in Visual Studio 2015. I open the profiler tab (Alt + F2) and select CPU Usage for instance, and click the Start button but nothing happens. I'm pretty sure this worked fine at some point in the past, but I can't say how long ago that was.

    I'm currently on Windows 10 Insider Preview build 14965. I installed VS 2017 RC yesterday and it seems to have the same problem.

    Has anyone experienced a problem like this before? Any idea how I can go about diagnosing the problem?


    Friday, November 18, 2016 6:41 PM

Answers

All replies

  • Hi Evan123456,

    How about other project type like the Windows Desktop app?

    Do you profile the same app in other VS2015 machine?

    Please profile your app in release mode, run the VS as the admin, check it again.

    I test it in my side, it works well, I use the VS2015 Enterprise version with the update 3, so please make sure that you use the latest version.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 21, 2016 10:36 AM
    Moderator
  • Hi Jack,

    Thanks for the suggestions, I didn't realize anyone had replied to this thread. I tried creating a new 'Universal Windows' project and it seems to have the same problem. Running as administrator doesn't seem to make a difference either.

    I did find another machine where I am able to launch the profiler for my project, but I have several machines that don't work. These are all VS 2015 Professional w/Update 3. The only difference I can think of is that the working machine only has VS 2012 and 2015 installed, while the others have 2010, 2012, 2013, and 2015. They're all running Windows 10. The problematic systems also have the Visual Assist X extension installed, but I tried disabling it and it didn't seem to make any difference.

    Evan

    Friday, December 16, 2016 2:23 AM
  • Hi Evan,

    Could you compare the version number under Help menu? Or you could install the latest kb for your vs under Tools->Extensions and Updates->Updates.

    For example, just create a default WPF app, and the use the same CPU Usage, remember to close the WPF UI after this tool starts, could you collect the performance for this WPF app in your machine? 

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, December 18, 2016 6:53 AM
    Moderator
  • Hi Jack,

    Both machines have the latest updates installed. This is the about page from the machine where the profiler works:

    And this is from one that has the problem:

    If I create a new default WPF application I see the same behavior as with my other applications. The working system can launch the app from the profiler tab and collect data, while on the one with the problem the 'start' button on the profiler tab doesn't do anything when I click it. I tried uninstalling VS 2013 from this machine since that was one of the differences between the two but it didn't make any difference.

    Thanks,

    Evan

    Monday, December 19, 2016 2:38 AM
  • Hi Evan,

    What are your two windows Environment?

    It seems that the .NET Framework version are different in your two VS versions, maybe we would think about the Windows Environment.

    I use the VS Enterprise with the same .NET version as your first one in my windows 10, it works well.

     

    Do you get any warning messages in the VS output window during you start the CPU usage?

    Not enable the Managed or Native Compatibility Mode under Tools –> Options –> Debugging, check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, December 19, 2016 12:03 PM
    Moderator
  • I just realized that the other thing the three problematic machines have in common is that they're all running Windows 10 "Insider Preview" builds (approximately the latest slow-ring builds available), and the two machines where the profiler tools work properly are running stock Windows 10. I suppose that could be the issue, maybe I should post this in some Windows 10 Insider forum, I'm not sure if they still exist?

    There's no information in the output window when I try to run the profiler, in fact I don't have a Diagnostics Hub option in the dropdown at all. Managed or Native Compatibility modes are not enabled (I tried enabling them too but it made no difference).

    Tuesday, December 20, 2016 6:29 AM
  • Hi Evan123456,

    I test it using the same windows Environment as yours, I got the same result as yours, I will help you report this issue later.

    Have a nice day,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 20, 2016 10:15 AM
    Moderator
  • The report link here:

    https://connect.microsoft.com/VisualStudio/feedbackdetail/view/3116928/performance-profiler-wont-launch-program-vs-2015

    You could add your comment and vote it.

    Have a nice day,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Evan123456 Wednesday, December 21, 2016 2:22 AM
    Tuesday, December 20, 2016 10:26 AM
    Moderator
  • Thanks for creating the report, I added my comments too. Glad we finally figured out what the cause of the problem was. Thanks again for all your help.
    Wednesday, December 21, 2016 2:22 AM
  • Thank you for submitting feedback on Visual Studio and the .NET Framework.  This is a known issue on Windows 10 Insider Preview. It is actually a bug in WPF, We've fixed the problem, and the change will be reflected in an upcoming Insider Preview release. There is no workaround and nothing that can be done. We are deeply appreciative for your commitment to help us build better products, and we hope this fix improves your experience with our tools and technologies.
    Thursday, December 22, 2016 7:24 AM