none
Call HTTP Web Service Retries Every 1 Minute RRS feed

  • Question

  • I currently have a SharePoint 2013 workflow setup. This workflow calls an HTTP Web Service using the HTTP Get Method. The web service takes over a minute to execute what it needs to and respond. The workflow retries calling the web service every 1 minute if it doesn't get a response back. This is causing issues as the process is already running and doesn't need to be run again. Is there some setting or response/request header value that I can set to prevent the workflow from retrying the web service call every minute?
    Thank You,
    Jon

    Wednesday, December 31, 2014 10:03 PM

Answers

  • Hi, I think you have to configure the default http timeout (WorkflowServiceMaxHttpResponseTime). You can find all passible wf manager settings inside WorkflowServiceConfig table of WFResourceManagementDB database. I suggest you to change those settings using powershell command. You can find more resources here http://msdn.microsoft.com/en-us/library/jj680843(v=azure.10).aspx (but have a look at the table content because not all settings are listed in the linked page.)

    Hope it helps

    • Marked as answer by jtereba Friday, July 24, 2015 6:08 PM
    Friday, January 2, 2015 2:33 PM

All replies

  • Hi,

     As per your posting, I believe there is no direct approach in the workflow to check the web service status for every call. 

    Let me try to work on that and try to give you the appropriate solution.


    Sekar - Our life is short, so help others to grow

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer


    • Edited by SekThang Thursday, January 1, 2015 5:19 AM
    Thursday, January 1, 2015 5:02 AM
  • Hi, I think you have to configure the default http timeout (WorkflowServiceMaxHttpResponseTime). You can find all passible wf manager settings inside WorkflowServiceConfig table of WFResourceManagementDB database. I suggest you to change those settings using powershell command. You can find more resources here http://msdn.microsoft.com/en-us/library/jj680843(v=azure.10).aspx (but have a look at the table content because not all settings are listed in the linked page.)

    Hope it helps

    • Marked as answer by jtereba Friday, July 24, 2015 6:08 PM
    Friday, January 2, 2015 2:33 PM