none
WebBrowser control: Invalid character on 'JSON'. RRS feed

  • Question

  • Hi,

    I'm running the same webpage on Chrome and in a WebBrowser control. As usual, it works fine with Chrome, but the WebBrowser doesn't like it. It's saying that there's an invalid character at where 'JSON' is in my JS file. I've added the registry key of the process name, with type DWORD and value 11000 at HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION.

    How can I fix this?

    Friday, May 3, 2019 8:59 AM

Answers

All replies

  • The key only changes behaviour for 32-bit applications on 64-bit systems, try change your compile target as "x86", or add/change the following registry key instead.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

    Friday, May 3, 2019 9:48 AM
    Answerer
  • Hi

    Is your problem solved? If so, please post "Mark as answer" to the appropriate answer, so that it will help other members to find the solution quickly if they face a similar issue.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, May 6, 2019 2:23 AM
    Moderator