locked
Debug Silverlight code via "Debug\Attach to Process..." in VS2015 RRS feed

  • Question

  • I used to be able to do this relatively easy, but since we moved onto VS2015, I can't find any way to make it work.

    The situation: we have a complex Silverlight app, uses CSLA to communicate with the server side. If something goes wrong on the server side, an exception might be raised there, while CSLA kindly sends it back to the Silverlight client, where we can consume it as needed. This works well, if we know what kind of exception may be raised, so that the client can handle it accordingly.
    Sometimes the exception is something which we didn't anticipate, or something else goes wrong, so we might want to do the following for a number of different reasons.

    The aim: I would like to be able to debug "only" the Silverlight client, while it is talking with the live server-side (and potentially a number of other services). This allows to gather information about what is happening in the live instance, which is hard to replicate on dev/test environments when something is going wrong, but we don't know what it is.

    However, when I try to Attach the debugger to a browser instance, I get a number of options, but no one seems to allow to debug Silverlight code (anymore). If I remember correctly, in VS2010 we had a "Debug these code types" entry for Silverlight specifically, while now I only get things like "Managed (CoreCLR)", "Managed (v4.6., v4.5, v4.0)" and more. I've tried everything I can think of, with no success.

    When debugging the whole thing (hit debug with the whole solution opened in VS) it all works. Moreover, the appropriate "Silverlight" option is already selected in the "type" column of the "attach to process" window (disabled, as it refers to a process that is already attached!). IOW, clearly my instance of VS is able to do what I need, but it merely refuses to.

    Any idea? Just telling me what "type" I should manually select (if any) would help, at least I'll know that if it isn't working it must be for some other reason...

    Thanks!
    Sergio

    Wednesday, August 24, 2016 2:23 PM

Answers

All replies