locked
After fresh install on Windows 10, it says "Unable to find Virtualbox" RRS feed

  • Question

  • User94279 posted

    I have Virtualbox 4.3 installed (came default with XAP)

    Edit: Just installed Virtualbox 5.0, but same error.

    Thursday, August 6, 2015 9:49 AM

All replies

  • User94279 posted

    Fixed it by adding "C:\Program Files\Oracle\VirtualBox" to my %PATH%

    Now downloading images.

    Thursday, August 6, 2015 10:00 AM
  • User71908 posted

    Hi @DimitriTholen, it seems that VirtualBox occasionally has problems adding it's path after installation. A restart can sometimes resolve this though. https://forums.virtualbox.org/viewtopic.php?f=6&t=64107

    Thursday, August 6, 2015 4:17 PM
  • User153560 posted

    ??

    Saturday, September 5, 2015 11:56 AM
  • User198887 posted

    gravedigging, but i have the same error. Could you provide me with an little more in-depth solution?

    Friday, February 26, 2016 8:40 AM
  • User199319 posted

    Also necromancing here, but seriously, it would be nice if Xamarin Player let us tell it where VirtualBox is installed instead of bloating our path further than needed.

    Saturday, February 27, 2016 5:33 AM
  • User199319 posted

    BUT ... I failed to thank you folks ... modifying my path fixed the issue for me, along with not allowing Xamarin to overwrite my VirtualBox installation. So essentially, I already had the latest VirtualBox installed, and when I installed Xamarin Android Player, I clicked cancel in the VirtualBox installer, but let the rest of the Xamarin installer run (why? because letting Xamarin install over my VBox previously left me with other problems). After this, modify the path to include the location of the VBox executables, and boom! everything's happy.

    MaartenHeebink, look in the Systems section in Control Panel. Then click advanced system settings, and finally environment variables. Add the location of VirtualBox.exe to the path. It is most likely something like C:\Program Files\Oracle\VirtualBox or C:\Program Files (x86)\Oracle\VirtualBox. Hope that helps.

    Saturday, February 27, 2016 5:45 AM
  • User213247 posted

    I am running Windows 10 Professional and did a clean installation. Had the same problem. I opened the environment variables and the "VBOXMSIINSTALL_PATH" was set to:

    C:\Program Files\Oracle\VirtualBox\

    I changed it to

    C:\Program Files\Oracle\VirtualBox

    and it worked for me.. (notice the last backslash)

    Friday, April 8, 2016 8:18 AM
  • User75709 posted

    Restart the pc works for me, Cheers :)

    Friday, April 15, 2016 8:36 AM
  • User135805 posted

    @nikobearrr said: I am running Windows 10 Professional and did a clean installation. Had the same problem. I opened the environment variables and the "VBOXMSIINSTALL_PATH" was set to:

    C:\Program Files\Oracle\VirtualBox\

    I changed it to

    C:\Program Files\Oracle\VirtualBox

    and it worked for me.. (notice the last backslash)

    So that's like.. broken. Like egregiously broken. I hope they avail themselves of endless free testing we give them. They bank too much on the fact their customers are devs.

    Monday, May 2, 2016 9:19 PM
  • User137122 posted

    VBOXMSIINSTALL_PATH deleting the last slash worked!

    Who has programmed that :-(

    Thursday, May 5, 2016 6:56 AM
  • User226787 posted

    Just restart your computer it will work.It work in this process for me.

    Thursday, May 19, 2016 1:12 PM
  • User253234 posted

    @DimitriTholen said: Fixed it by adding "C:\Program Files\Oracle\VirtualBox" to my %PATH%

    Now downloading images.

    Thanks!

    Tuesday, August 30, 2016 3:18 PM