locked
SQL SERVER 2017 returns error "Expected 1 export(s) with contract name "Microsoft.VisualStudio.Utilities.IContentTypeRegistryService" but found 0 after applying applicable cons" RRS feed

  • Question

  • User1182587605 posted

    Hi

    I have installed VS 2017 recently and since then I have an issue in my SQL SERVER 2017. SQL server connects t the server but when I want to run a query or get top 1000 rows, I get an error popup message "TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    Expected 1 export(s) with contract name "Microsoft.VisualStudio.Utilities.IContentTypeRegistryService" but found 0 after applying applicable constraints. (mscorlib)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------
    "

    I have repaired the SQL server with the setup file but still I have the same issue. Please help me know what I need to do in order to get the SQL SERVER run the projects once again.

    Thanks,

    Deepak 

    Thursday, August 24, 2017 7:49 AM

All replies

  • User1771544211 posted

    Hi Deepak,

    Based on your description, It seems that the issue is with Visual Studio Isolated shell. Please try clean the Visual Studio Component Model Cache. Just delete or rename this folder.

    For VS 2017 it should be :

    %AppData%\..\Local\Microsoft\VisualStudio\15.0\ComponentModelCache

    Best Regards,

    Jean

    Friday, August 25, 2017 6:07 AM
  • User-1893288352 posted

    Hello,

    I have the same issue after doing windows update, I removed the cache, reinstalled vs_isoshell, reinstalled the SQL management studio and removed the 14.0_Config from the regedit

     none of them is working :(, 

    best regards

    Wednesday, January 24, 2018 2:37 PM
  • User-1461988207 posted

    I also encountered this issue. is there any resolution?

    I have tried to delete ComponentModelCache folder on C:\Users\{user}\AppData\Local\Microsoft\VisualStudio\14.0, but it was still not working

    Thanks,

    Haven

    Saturday, November 9, 2019 7:52 AM