Async-CTP-v3 installation problem RRS feed

  • Question

  • Hi,

    I know many questions were asked about the installation problem. I tried the solution I found on this forum but still can't successfully install the CTP v3. I seem to be in a similar situation as the guy here: http://social.msdn.microsoft.com/Forums/en-US/async/thread/de9c9811-ee61-4fa1-9ee4-e3df6ac756ff. The installation doesn't give any error.

    The DLL versions after install are:

    • csc.exe: 4.0.30319.517
    • vbc.exe: 10.0.30319.517
    • msvbide.dll: 10.0.40219.1
    • My Documents\Microsoft Visual Studio Async CTP: No such folder

    I run VS2010 Pro + SP1. My "My Documents" is not shared and is at the default location (under c:\users\*me*). I had the Silverlight Tools 5 SDK Beta installed: I removed it and tried reinstalling. I can't find KB2615527 in my updates (ref. http://social.msdn.microsoft.com/Forums/en-US/async/thread/8faf9f46-8ecd-4750-9b9e-9579d784d383).

    I looked at the installation log and it has a lot of things like this (the following is the first one):
    Error 2746:  Transform RTM.1 invalid for package C:\Windows\Installer\2ac5a.msi. Expected product {ED784556-66AA-3F17-9B58-7246ACB5C7E4}, found product {D6B15AE6-B052-363E-B6BB-C4714CBA6509}.

    One thing that may be worth noting is that I installed the developer preview of VS 11 and uninstalled it (not without pain, I had to manually uninstall .Net 4.5 and reinstall .Net 4, as well as VS2010 + SP1, IIS, AppFabric, etc...) before I tried to install the Async CTP.

    Thanks for your help,


    Friday, January 27, 2012 11:10 PM


All replies

  • Hi Gabriel

    Did you get this working, I have the same config and also have a problem with this.




    Sorry  KB2615527 was on my system.(I Never Clicked on View Installed Updates).

    Once I removed it the Async CTP v3 installed fine.


    • Edited by Dean White Monday, February 13, 2012 5:54 AM Problem solved
    Monday, February 13, 2012 4:56 AM
  • Glad it works for you.

    I personally gave up: I don't seem to have KB2615527 installed and after spending a day and a half trying to install the CTP, I can't imagine asking every one in the office doing the same. The would probably find other issues too.

    My hope was to use the CTP until .Net 4.5 comes out and they move on. However, since the rumors are that 4.5 won't support WinXP, I don't think I'll can upgrade, so I am less motivated in getting the CTP to work.


    Monday, February 13, 2012 2:16 PM
  • Did you check that KB2635973 is installed on your machine? It will also prevent from Async CTP from installing.


    Avner Aharoni

    Wednesday, February 29, 2012 7:51 PM
  • I am on Window XP 64 Bit.  I can't upgrade to Win 7 because my employer won't allow it.  None of the mentioned KBs are installed KB2635973, KB2549864.  Async CTP will not install.
    Wednesday, April 25, 2012 12:11 AM
  • Do you have KB2645410? This is a security update that was issued on March 9. If you have it you need to uninstall it before installing the Async CTP and then you can reinstall it.

    Avner Aharoni

    • Proposed as answer by LinoB Thursday, August 23, 2012 8:30 AM
    Wednesday, April 25, 2012 12:22 AM
  • Avner  - Thank You!  Removing KB2645410 did the trick.  
    Wednesday, April 25, 2012 1:27 AM
  • Hi all

    Nothing helps in my case with an exception that I don't have kb2645410

    I removed silverlight altogether, all mvc and all the kbs mentioned -

    This is so strange, - I've never had any problems with installations in all my life//

    Monday, May 14, 2012 2:33 PM
  • Can you send the list of the KBs that are installed on your machine?

    Avner Aharoni

    Monday, May 14, 2012 2:48 PM
  • Same here.
    Thursday, August 23, 2012 8:46 AM
  • Hi,

    This might help.


    Happy Coding.



    Jaliya Udagedara(MCPD) http://www.jaliyaudagedara.blogspot.com

    Wednesday, August 29, 2012 11:52 AM