locked
RC0 Website Authentication Settings RRS feed

  • Question

  • in RC0, I am finding that http://<web server>/MDS/service/service.svc/bhb (used by Excel addin) requires anonymous authentication enabled in IIS, and for Windows authentication, extended protection is off.  However, this causes the Master Data Manager to stop functioning, showing "Unauthorized".  Could you please detail all the IIS settings to get both the Excel addin and Master Data manager to work ? 

    btw, in CTP3 I found that I had to disable anonymous authentication...


    Mark
    Monday, November 21, 2011 5:22 PM

Answers

  • The Config Manager creates new MDS web sites with the authentication settings that MDS needs. It should not be necessary to make manual changes. In fact, such changes may break the web site and/or the WCF web service that the Excel add-in and Silverlight UI use. To fix, you can delete the broken web application and then recreate it with Config Manager. Or, you can try manually restoring the authentication settings. Go to IIS Manager and ensure that the MDS web site has Windows Authentication enabled and Anonymous Authentication disabled. Then expand the MDS folder and enable Anonymous Authentication on the "Service" subfolder.

     

    • Proposed as answer by Brent Mc - MSFT Wednesday, November 23, 2011 12:02 AM
    • Marked as answer by MGsch Sunday, November 27, 2011 6:35 PM
    Monday, November 21, 2011 8:38 PM

All replies

  • The Config Manager creates new MDS web sites with the authentication settings that MDS needs. It should not be necessary to make manual changes. In fact, such changes may break the web site and/or the WCF web service that the Excel add-in and Silverlight UI use. To fix, you can delete the broken web application and then recreate it with Config Manager. Or, you can try manually restoring the authentication settings. Go to IIS Manager and ensure that the MDS web site has Windows Authentication enabled and Anonymous Authentication disabled. Then expand the MDS folder and enable Anonymous Authentication on the "Service" subfolder.

     

    • Proposed as answer by Brent Mc - MSFT Wednesday, November 23, 2011 12:02 AM
    • Marked as answer by MGsch Sunday, November 27, 2011 6:35 PM
    Monday, November 21, 2011 8:38 PM
  • The issue was the authentication for the Service folder.  For some reason, Anonymous was not enabled before, and enabling it fixed the issue.  Thanks, Brent.  btw, I think it is helpful to let others see this documentation for authentication settings.


    Mark
    Sunday, November 27, 2011 6:37 PM
  • Hi Brent, I tried doing the following but still getting the same error:

    Tried two other links, but haven't been able to get thru this issue.

    http://algour.com/2013/09/10/mds-issue/ 

    http://blogs.technet.com/b/beatrice_popa/archive/2013/01/31/master-data-services-issue-with-https-error-message-httpwebrequest-webexception-remoteserver-arguments-notfound-debugging-resource-strings-are-unavailable.aspx

    It looks like there is some configuration is missing/incomplete in the mds web.config file.

    Another thing: While configuring the web application for MDS I had this error... unable to get rid of this too...

    Before creating an MDS web application, you must correct the following errors:

                    Internet Information Services (IIS) is not configured on this server.

                                    The required .svc handler mappings are not installed in IIS. For more information, see http://go.microsoft.com/fwlink/?LinkId=226284.

                    For web application requirements, see http://go.microsoft.com/fwlink/?LinkId=215355.


    Abhishek Madan


    This is the RTM version
    • Edited by Abhishek (Madan) Tuesday, September 17, 2013 2:28 PM little addition
    Tuesday, September 17, 2013 2:27 PM