Linked DB2 server cannot do SQL inserts


  • We have a SQL server with a linked server to our i-Series. The linked server is set up with a provider of IBM DB2 UDB for i-Series OLE DB. When we try and run SQL statements against this linked server we can do everything but an INSERT.  When we try and run an insert we get the following error.

    OLE DB error trace [OLE/DB Provider 'IBMDA400' IRowsetChange::InsertRow returned 0x80040e53:  The provider does not support the necessary method.].
    Msg 7399, Level 16, State 1, Line 1
    OLE DB provider 'IBMDA400' reported an error. The provider does not support the necessary method.

    We do have the provider (IBMDA400 was the only IBM one that shows up) checked for "ALLOW IN PROCESS"

    It's been a couple of days of Google searching and tried a lot of suggestions but still no luck with an insert.

    Any ideas as to a solution ?

    Thanks in advance

    Wednesday, July 03, 2013 2:56 PM

All replies

  • Check if MS DTC service is running on both servers and it is configured correctly to allow distribured queries

    Thanks and Regards, Prajesh Please use Marked as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    Monday, July 22, 2013 1:45 PM