none
Problem running a hyper-v container on Windows 10 Insider Preview build 14342 => "Not enough storage is available" RRS feed

  • Question

  • C:\Windows\system32>docker run --rm -it --isolation=hyperv --name test nanoserver cmd
    docker: Error response from daemon: HCSShim::CreateComputeSystem failed in Win32: Not enough storage is available to complete this operation. (0xe) id=9fa95f91869b941cc2aad16d1d699b18db4954429ec9b92e5c0f6fae99291a59 configuration={"SystemType":"Container","Name":"9fa95f91869b941cc2aad16d1d699b18db4954429ec9b92e5c0f6fae99291a59","Owner":"docker","IsDummy":false,"VolumePath":"","Devices":null,"IgnoreFlushesDuringBoot":true,"LayerFolderPath":"C:\\ProgramData\\docker\\windowsfilter\\9fa95f91869b941cc2aad16d1d699b18db4954429ec9b92e5c0f6fae99291a59","Layers":[{"ID":"4adbd01e-9c09-5835-b9eb-26e3ea05c047","Path":"C:\\ProgramData\\Microsoft\\Windows\\Images\\CN=Microsoft_NanoServer_10.0.14300.1010"}],"HostName":"9fa95f91869b","MappedDirectories":[],"SandboxPath":"C:\\ProgramData\\docker\\windowsfilter","HvPartition":true,"EndpointList":["744a421a-63fb-49b1-adcf-c9cb99a5c372"],"HvRuntime":{},"Servicing":false}.

    Any ideas most welcome!

    Friday, May 27, 2016 4:51 AM

All replies

  • If anyone has the problem, I solved it.

    Basically, I was trying to do all this in a VM running on normal Windows 10, not Insider Preview, so there was no nested visualization for the Hyper-V container.

    After installing Server2016 TP5, then a windows 10 Insider Preview build 14352 image within a Hyper-V container with nested visualization, I was able to do this.

    Friday, June 3, 2016 12:30 AM
  • when I  am running  [ docker run   --isolation=hyperv  nanoserver cmd ]  ,  I get  the  same error .  how to solve it ?  thanks.
    Wednesday, June 29, 2016 8:11 AM
  • He said it very clearly, you need to enable nested virtualization, given you are running VMPlayer, it will not work. You can try to install TP5 or Windows 10 Insider Preview directly on the hardware then try again.
    Wednesday, June 29, 2016 9:52 AM
  • Glad to hear it is sorted out, the error message is misleading. Here is more information on the issue:

    https://github.com/Microsoft/Virtualization-Documentation/issues/304

    neilp

    Wednesday, June 29, 2016 4:34 PM