none
Need a fresh install RRS feed

  • Question

  • If anyone can help please?

    I am unable to uninstall Visual Studio 2015.

    I want to uninstall it, to reinstall and start from fresh, as I am having trouble installing any of the project packs. I continually receive this is the error:

    Community 2015 Setup blocked

    Correct the following problems: 1) Computer needs to be restarted. 2) close visual studio to reduce the change of a computer restart.

    Every time I do a restart I continue to get the same Setup Blocked issue.

    If you need anymore info to assist please let me know.

    Tuesday, December 29, 2015 7:57 AM

Answers

  • Hi Tug82,

    Thank you for posting in MSDN forum.

    From your description, I suspect maybe your VS install package is corrupted or missing, in this situation, if you want to uninstall, you need to use a healthy iso image to repair it first.

    Since you didn’t mention in which way you installed VS, web installer or iso image,
    To eliminate internet variables, I suggest that you download the ISO, verify the SHA-1 to ensure the ISO is not corrupt, then install locally.
    VS 2015 iso Microsoft official download link:
    https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx
    VS 2015 iso files SHA-1 Values link:
    https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

    PS: To make sure whether your package is corrupted or not,
    please use FCIV.exe http://support.microsoft.com/kb/841290  to verify hash of the ISO.
    Any discrepancy would indicate that the file was corrupted. Here is a blog for how to use it, you can refer to it.

    After making sure that the iso is ok, you could use it to repair and then re-install.

    Besides, in order to narrow down the problems of VS setup, there are some tips about installing VS:
    1. Disable anti-virus or anti-spyware software.
    2. Check windows update.
    3. Clear %TEMP% folder.
    4. Run the installer as administrator.
    you should make sure you’ve followed these tips:  http://social.msdn.microsoft.com/Forums/en/vssetup/thread/60f71a54-506e-4c70-be98-e993ce6d1ddf
    If the above still doesn't help, I need you installation log file to troubleshoot this issue,
    please use  http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to  https://onedrive.live.com/ and share the link here

    Best Regards,
    Wen Xu 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, December 30, 2015 9:05 AM
    Moderator