locked
I don't see these in the web.conig <membership><providers> RRS feed

  • Question

  • User-954169400 posted

    I'm reading Scott Mitchells tutorials on ASP.net membership and using the Time tracker site.


    I don't see this in the web.config


    <add name="AspNetSqlMembershipProvider"
    type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    connectionStringName="LocalSqlServer"
    enablePasswordRetrieval="false"
    enablePasswordReset="true"
    requiresQuestionAndAnswer="true"
    applicationName="/"
    requiresUniqueEmail="false"
    passwordFormat="Hashed"
    maxInvalidPasswordAttempts="5"
    minRequiredPasswordLength="7"
    minRequiredNonalphanumericCharacters="1"
    passwordAttemptWindow="10"
    passwordStrengthRegularExpression=""/>
    </providers>
    </membership>


    I've searched and don't see it.   Can someone tell me how to find it?

    Friday, November 12, 2010 3:45 PM

All replies

  • User541108374 posted

    Hi,

    if you don't see it in your web.config then it'll still work as web.config files are nothing more than overrides of another web.config file, ultimately the one in the Microsoft.NET framework folder itself.

    Grz, Kris.

    Friday, November 12, 2010 4:29 PM
  • User421672444 posted

    bu default web config does not contain those code. it is generated automatically if you use the Web Site Administration Tool to configure roles and membership and so on, while you can also configure manually.. see this excellent video which explains http://www.asp.net/security/videos/understanding-aspnet-memberships

    Friday, November 12, 2010 4:54 PM
  • User-954169400 posted

    I amusing the Web Site Administration tool to manage users and roles and users.   Should I go to machine.config and copy the code to my web.config and make the changes there?  I want to get rid of the requirement to use 1 non-alphanumeric character.

    Saturday, November 13, 2010 10:54 PM
  • User541108374 posted

    Hi,

    Should I go to machine.config and copy the code to my web.config and make the changes there?

    You can but then you have that change on all of your applications that run on that machine. So be aware of that consequence before doing so.

    I want to get rid of the requirement to use 1 non-alphanumeric character.

    You can change it in your current web.config which you posted in your original question and change this setting: minRequiredNonalphanumericCharacters="1" to 0.

    Grz, Kris.

    Sunday, November 14, 2010 3:10 AM