locked
CreateQuery Returns Only One Item... RRS feed

  • Question

  • I am using the System.Web.Extensions 3.5 (3/6/08 version), and I'm trying to create a WebContext based off the Northwind model from the ADO.NET Samples.

     

    I am able to reget a WebDataQuery back from my context by calling context.CreateQuery<Supplier>( "/Suppliers" ).  However, when I enumerate over this result, or call .ToArray() on it, the result only returns one item.  Is there something I am completely overlooking?

     

    To make things more interesting... if I view the Uri in a browser, the full list of Suppliers shows up as expected...

     

    Btw, a Sample Solution somewhere that has everything working correctly on a sample domain model would be FANTASTIC. Smile

     

    Thanks!

    Friday, April 4, 2008 2:30 AM

Answers

  • There is no workaround for this problem. Only thing i can say is to wait for the beta bits, which should be out soon.

     

    Thanks

    Pratik

    Wednesday, April 30, 2008 4:18 PM
    Moderator

All replies

  • I believe you have run into the same bug as decribed here:

     

    http://forums.microsoft.com/forums/ShowPost.aspx?PostID=3110104&SiteID=1

     

    Should be fixed in the next public release.

     

    Friday, April 4, 2008 7:03 PM
    Moderator
  • Hmmm... I'm not using any expand, but yes, it does sound familiar.  Is there a sample solution somewhere that has a working model to work from?

     

     

    At the risk of asking "are we there yet?" ... any idea when this next release will be out? Smile

     

    Friday, April 4, 2008 10:25 PM
  • There is no workaround for this problem. Only thing i can say is to wait for the beta bits, which should be out soon.

     

    Thanks

    Pratik

    Wednesday, April 30, 2008 4:18 PM
    Moderator