locked
VS 2012/Silverlight 5 .net 4.7 not installed RRS feed

  • Question

  • User-1522356873 posted

    I have an older Silverlight project using VS 2012 that I need to make some changes to, when I open it in VS 2012 I get the error indicating that the project is targeting the 4.7 framework and that it's not installed, do I want to download it.

    The current framework installed is 4.7.1, but VS cannot detect it, what could be causing this. I have confirmed that 4.7.1 is installed.

    I also have .Net Core installed but I don't see why that would interfere.

    Thanks

    Monday, April 9, 2018 7:59 PM

All replies

  • User347430248 posted

    Hi LostFrench...,

    Is your old project developed using .Net Framework 4.7?

    Is .Net Framework 4.7 is listed under the list of .Net Frameworks in Visual Studio 2012?

    Try to check it and let us know about it.

    Did you try to download the .Net Framework 4.7 from the prompt displayed by the Visual Studio, If you did not try to then try to install it from that prompt and check whether it overwrites the current .Net Framework 4.7 or not.

    It can solve your issue.

    I don't think that .Net Core will affect this issue in any way.

    Regards

    Deepak

    Tuesday, April 10, 2018 6:43 AM
  • User1813949509 posted

    Thanks for the help

    Tuesday, June 5, 2018 7:26 AM