none
Outbound EDIFACT without sender or Recipient qualifiers RRS feed

  • Question

  • I can generate outbound EDIFACT without problems if I include the Sender and Recipient Qualifiers (UNB2.2 & UNB3.2). However, if I try to send EDIFACT with using the qualifiers it always inserts the DEFAULT UNB settings 

     

    UNB+UNOC:1+BTS-SENDER:ZZZ+RECEIVE-PARTNER+070724:1456+17++++0'

     

    If I check the message context of the generated file, both the DestinationParyReceiverIdentifier and the DestinationParySenderIdentifier are set correctly.

     

    Do I need to specifically set the DestinationParyReceiverQualifier and DestinationPartySenderQualifier to NULL or something ?

    Tuesday, July 24, 2007 1:08 PM

Answers

  • Could you answer a few questions for me to better understand your scenario?

    "I can generate outbound EDIFACT without problems if I include the Sender and Recipient Qualifiers (UNB2.2 & UNB3.2). However, if I try to send EDIFACT with using the qualifiers it always inserts the DEFAULT UNB settings"

    [Mohsin] - What do you mean by when you say "if I include Sender and Recepient Qualifier"? Where do you include them? Do you mean to say when you set these values under Party as Interchange Receiver?

     

    "Do I need to specifically set the DestinationParyReceiverQualifier and DestinationPartySenderQualifier to NULL or something ?"

    [Mohsin] - Resolving party for send side does not make use of these values. The way Party resolution works on the send side is as follows.

     

    1. Use the context property DestinationPartyName to match the party name in PAM

     

    2. If not present, it uses four context properties mentioned below and matches them with the Sender and Receiver ids and qualifiers in Party as Interchange Receiver fields

       - Four properties are: EDI.DestSenderId, EDI.DestSenderQual, EDI.DestReceiverId and EDI.DestReceiverQual

       - Namespace: http://schema.microsoft.com/Edi/PropertySchema

       - PAM validation ensures this quartet is unique among all parties

     

    3. Resolve based on party associated with send port

     

    4. Finally use global

     

    Hopefully this should answer your questions. Please let me know if you need further clarification.

     

    Thanks

    Mohsin

    Wednesday, July 25, 2007 12:36 AM
  • Sorry about the confusion. You are right about the names of the context properties. As for the other part of just using the identifiers, you need to have all the four properties match on the send side for a party settings to be applied. Partial matches are not accepted.

     

    Thanks

    Wednesday, July 25, 2007 7:11 PM

All replies

  • Could you answer a few questions for me to better understand your scenario?

    "I can generate outbound EDIFACT without problems if I include the Sender and Recipient Qualifiers (UNB2.2 & UNB3.2). However, if I try to send EDIFACT with using the qualifiers it always inserts the DEFAULT UNB settings"

    [Mohsin] - What do you mean by when you say "if I include Sender and Recepient Qualifier"? Where do you include them? Do you mean to say when you set these values under Party as Interchange Receiver?

     

    "Do I need to specifically set the DestinationParyReceiverQualifier and DestinationPartySenderQualifier to NULL or something ?"

    [Mohsin] - Resolving party for send side does not make use of these values. The way Party resolution works on the send side is as follows.

     

    1. Use the context property DestinationPartyName to match the party name in PAM

     

    2. If not present, it uses four context properties mentioned below and matches them with the Sender and Receiver ids and qualifiers in Party as Interchange Receiver fields

       - Four properties are: EDI.DestSenderId, EDI.DestSenderQual, EDI.DestReceiverId and EDI.DestReceiverQual

       - Namespace: http://schema.microsoft.com/Edi/PropertySchema

       - PAM validation ensures this quartet is unique among all parties

     

    3. Resolve based on party associated with send port

     

    4. Finally use global

     

    Hopefully this should answer your questions. Please let me know if you need further clarification.

     

    Thanks

    Mohsin

    Wednesday, July 25, 2007 12:36 AM
  • Where did you find "...Four properties are: EDI.DestSenderId, EDI.DestSenderQual, EDI.DestReceiverId and EDI.DestReceiverQual..." ?

     

    On the BizTalk Server 2006 R2 - EDI Product Team Blog it specifies "...For outbound transactions, four new context properties have been added: EDI.DestinationPartyReceiverIdentifier, EDI.DestinationPartyReceiverQualifier, EDI.DestinationPartySenderIdentifier, and EDI.DestinationPartySenderQualifier..." and this works fine if I use all 4 as in -

     

    EDIFACTmsgOut(EDI.DestinationPartySenderIdentifier) = "RCSINTERNATIONAL";

    EDIFACTmsgOut(EDI.DestinationPartySenderQualifier) = "14";

    EDIFACTmsgOut(EDI.DestinationPartyReceiverIdentifier) = "INNTOU";

    EDIFACTmsgOut(EDI.DestinationPartyReceiverQualifier) = "14";

     

    However, if I only use the Identifiers it does not work, as in -

     

    EDIFACTmsgOut(EDI.DestinationPartySenderIdentifier) = XMLmsgIn.Header.SendParty;

    EDIFACTmsgOut(EDI.DestinationPartyReceiverIdentifier) = XMLmsgIn.Header.RecvParty;

     

    By the way, I have checked to ensure the correct values are being set in the context and that they match the setup in the Parties EDI configuration.

    Wednesday, July 25, 2007 6:27 AM
  • Sorry about the confusion. You are right about the names of the context properties. As for the other part of just using the identifiers, you need to have all the four properties match on the send side for a party settings to be applied. Partial matches are not accepted.

     

    Thanks

    Wednesday, July 25, 2007 7:11 PM
  • So his brings me back to my original question - what should I use to represent the DestinationPartySenderQualifier and DestinationPartyRecipientQualifier if they are not used ? I have tried "" and "<Not valued>" but niether work.

     

    Thursday, July 26, 2007 6:45 AM
  • Richard, I am not sure if I understand your question correctly. Could you please email me your number and we can set up a teleconference call to help resolve your issue. For privacy reasons I won't post my email here. You can get it from my profile.

     

    Thanks and looking forward for your email

    Mohsin

    Thursday, July 26, 2007 8:54 PM