locked
How to enable gestures on iiyama ProLite T1931SR

    Question

  • I have attached Windows 8 Developer Preview to the iiyama ProLite T1931SR which is a single-touch LCD monitor. "Clicking" works as expected, but gestures not. I have also tried the drivers from iiyama website, but no help. I have observed that the mouse pointer follows my finger, so it seems like my finger is treated as a mouse, instead of a finger.

    Examples of what does not work:

    • Scrolling in the Start menu.
    • Sliding to show the App Bar.
    • Sliding to show charm right bar.
    • Touching left bottom to show the Start - Search - Share Device - Settings menu.
    • Sliding to switch to another app.
    • Scrolling in a combo box in desktop IE.

    Also, if I run the Pen and Touch control panel (which is available only until I install the drivers from iiyama website) and choose to Practive using flicks and slide with my finger over the testing box, I get an error "You cannot use a mouse to perform a flick. Try again using your tablet pen or finger."

    Is there a way how to get the touches to be treated as touches and not as mouse clicks and so the gestures to work?



    • Edited by MCCZ Monday, September 26, 2011 6:54 PM
    Monday, September 26, 2011 6:35 PM

All replies

  • MCCZ,

    I am sorry to hear about your issues, have you downloaded the most current drivers for Windows 7 from the manufacturer’s website?  If not then give that a try to see if it fixes your issues.

    If that doesn't work, then try to install the drivers in compatibility mode to see if that resolves the problem.

    You can do this by:

    ·         Enter the Start screen

    ·         Move your mouse to the bottom left of the screen to expand the Charms section

    ·         Select Search

    ·         Type Compatibility

    ·         Click Settings in the right column

    ·         Click Run programs made for previous versions of Windows

    ·         Then follow the prompts and direct the troubleshooter to the installer for your computer's driver.

    Please post back with your results.

    Thanks,


    Chris
    Tuesday, September 27, 2011 3:31 PM
  • Hi Chris,

    thank you for your reply.

    Yes, I have already tried the newest drivers from the manufacturer's website and they seems to install correctly even without running them in a compatibility mode.

    However, my touches are translated into mouse events instead of touch events. This behaviour does not depend on drivers used - I have tried both the generic one and the newest vendor's one.

    Tuesday, September 27, 2011 4:39 PM
  • MCCZ,

    It sounds like this is a driver issue.  Please post here the driver version and the location of the driver download and we will make sure the information is passed on to the right feature group for review.

    Thanks,


    Chris
    Saturday, October 01, 2011 3:10 PM
  • Hi Chris,

    I've downloaded drivers from the vendor site http://www.iiyama.com/cz_cs/podpora/stahni/1719.download (linked from http://www.iiyama.com/cz_cs/podpora/stahni/). With this installed, I see "USB Touchscreen Controller(Universal)" item in the "Mice and other pointing devices" (driver provider eGalaxTouch / date 10.11.2009 / version 5.8.0.7210).

    Monday, October 03, 2011 3:26 PM
  • If this is a drivers issue, then it also affects the n-trig drivers on the HP TX2. Finger flicks are not recognized, but the same flicks are perfectly fine if done with the pen (i'm talking about the same flicks as MCCZ, not the ones to bring up the charms and menus).

     

    I also get the mouse message when trying to train the flicks, just as the OP has reported. This is on totally different hardware.

     

     

    Monday, October 03, 2011 6:23 PM