none
Additional assemblies not referenced copied to bin folder in VS 2015

    Question

  • I have a asp.net web application that uses several 3rd party assemblies. For ease of deployment, I put all of my assemblies I need into a local components folder and reference those instead of letting the references being added from the GAC (the 3rd party tool is DevExpress so it is installed). In previous versions of Visual Studio (up to 2013), when I deployed the web application, the only assemblies that were in the bin folder were the ones I had references for. It seems that VS 2015 has changed something because now it is pulling adding additional assemblies and placing them in my deployed bin folder. The added assemblies are not referenced by my project and I have verified with DevExpress that they are not used or needed given the references that I have currently added to my project. If I take the same project with the same structure in VS2013, only those referenced assemblies get copied to the deployed bin folder.

    Has anyone experienced this or know if there is a setting to fix this?  For my references in my project, I am referencing a local folder (i.e. D:\Projects\MyWebsite\Components\) and I have set the Copy Local property to true for those references so that they get copied over to the bin folder when I publish my website.

    Thanks,
    Greg

    • Moved by Jamles Hez Monday, December 7, 2015 2:39 AM
    Tuesday, December 1, 2015 3:33 PM

Answers

All replies

  • Hi Greg,

    Will move the question to Visual Studio General forum.

    >>when I deployed the web application, the only assemblies that were in the bin folder were the ones I had references for.

    Basically as I know since Visual Studio 2015, it reference all assemblies automatically.

    Here is what I see from VS2013

    Below is what I can see from VS2015

    >>I put all of my assemblies I need into a local components folder and reference those instead of letting the references being added from the GAC

    You can change the alias from global to another name and then use following code to do the GAC:

    extern alias firstAlias;
    extern alias secondAlias;
    
    using FirstBar = firstAlias::class.method;
    using SecondBar = secondAlias::class.method;

    --James


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 2, 2015 5:57 AM
  • Hi Jamles,

    Sorry, didn't know which forum to put this in.  It appears that this is probably a DevExpress problem after all.  Somehow, if I included one of their assemblies in the references, it copies over 3-4 more "optional" assemblies that is associated with it that I don't reference. 

    I'm not referring to the Copy Local as the problem here.  It is set to true in both VS2013 and VS2015 for my project.  The problem arises with this specific version of DevExpress and I am working with them on this to gather more information.  If I find out it is not their issue, I will post back here.

    Thanks,
    Greg

    Wednesday, December 2, 2015 2:28 PM
  • Hi Greg,

    >>I'm not referring to the Copy Local as the problem here.  It is set to true in both VS2013 and VS2015 for my project.  The problem arises with this specific version of DevExpress and I am working with them on this to gather more information.  If I find out it is not their issue, I will post back here.

    How about the issue now? Would you mind letting us know the latest information about this issue?

    I'm not very sure that whether you discuss this issue with the DevExpress experts, but as far as I know, it has his own support site here:

    https://www.devexpress.com/Support/Center/Question/List/1

    If this issue is just related to the DevExpress, I suggest you post this issue in above site.

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you.

    Microsoft does not control these sites and has not tested any software or information found on these sites;

    Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

    There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Thanks

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 7, 2015 9:13 AM
    Moderator
  • Hi Jack,

    The issue still exists because of the way VS 2015 handles deployment of the referenced assemblies.  I talked with DevExpress and it is not their controls.  Something changed in the way VS 2015 builds an application (either Winforms or ASP.NET).  They referred to the following article but changing the property to False is not the solution.  When the property is true, the logic involved in copying the referenced assemblies has changed since VS 2013.

    https://connect.microsoft.com/VisualStudio/feedback/details/1572417/the-default-setting-for-the-local-copy-of-references-is-now-true

    I don't know what more to add to this.  I'm just manually removing the extra assemblies that I don't need for now.  Maybe an update can revert back to the way it was because in my opinion, VS should just copy what you have referenced in your project like it has in past versions of VS.

    Thanks,
    Greg

    Tuesday, December 8, 2015 4:21 PM
  • Hi Greg,

    Thanks for sharing the connect report for the "copy local" property issue, but as the product team members' reply, it seems that it is by design in the VS2015 now, so maybe remove them manually or change the property setting to be false for the references  is a workaround for this issue now.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 9, 2015 12:40 PM
    Moderator