locked
VS 2010 Ultimate hangs while running MSTests RRS feed

  • Question

  • I have Visual Stuio 2010 Ultimate installed in my Win 7 machine.

    Whenever I try to run MSTest on it, it shows the busy cursor and if I click on the VS anywhere it shows me "Visual Studio is busy" and it never comes back.

    This has been working fine from the day I installed(Dec 2010) and it stoped working a month ago or two; may be from May 2012.

    Even I cannot open the test results that I got from my CI build, it hangs and never come back.

    Any help to fix this is appreciated.

    Thanks.

    Tuesday, July 10, 2012 3:53 PM

Answers

  • Hi Natesan ,

    Glad to receive your reply.

    If possible, I suggest you close other apps when you run your test with VS, you could check your Task Manager, make sure that it is not busy.

    If it has the same issue when you run a simple test with MSTest, I doubt that it is related to your VS, and if possible, I suggest you try to check it with the following steps.

    You need locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    After these, check it again, if it has the same issue, I’m afraid that you would try to repair your VS and check it.

    Note:  Please install SP1.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, July 13, 2012 6:48 AM

All replies

  • Hi Natesan,

    Thank you for posting in the MSDN forum.

    Do you mean that the VS will hangs when you use the MSTest to run all tests? Maybe you could try to run your test with VS, does it have the same issue? How about restarting your pc?

    If you open your VS in SafeMode, then run your tests with MSTest, whether it has the same issue?

    I doubt that the extension installed in your PC may prevent it from running tests, to make sure that it is not the VS issue, I suggest you try to run the test with another pc, if it works well, I’m afraid that it is related to your VS, maybe you could try to reset your VS settings or repair your VS and check it.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, July 12, 2012 7:15 AM
  • Hi Jack,

    Thanks for the help.

    After restarting my machine it didnt work, but after several re-starts of my machine its working now.

    I do not completely rely on this fix! Let me take some more time and watch this and comeback to this thread.

    Thanks.


    Natesan Jayaraman

    Thursday, July 12, 2012 4:26 PM
  • I have my solution opened in VS 2010 and I right click on [TestClass] attribute and Run Tests from the popu window, it shows the busy cursor and if just click on the screen it shows the busy message.

    "Microsoft Visual Studio is Busy

    Microsoft Visual Studio is waiting for an internal operation to complete. If you regularly encounter this delay during normal usage, please report this problem to Microsoft. "

    Even if I wait for hours its not working, so I had to kill the process and open another instance of VS and use some other tool to run the test cases.


    Natesan Jayaraman

    Thursday, July 12, 2012 9:44 PM
  • Hi Natesan ,

    Glad to receive your reply.

    If possible, I suggest you close other apps when you run your test with VS, you could check your Task Manager, make sure that it is not busy.

    If it has the same issue when you run a simple test with MSTest, I doubt that it is related to your VS, and if possible, I suggest you try to check it with the following steps.

    You need locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    After these, check it again, if it has the same issue, I’m afraid that you would try to repair your VS and check it.

    Note:  Please install SP1.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, July 13, 2012 6:48 AM