locked
Crystal Report Printing Error RRS feed

  • Question

  • User-1946277446 posted

    Hi All,

    When I try to print a Crystal Report in the Enterprise view I get an error 'An error occurred on the server. Printing will be stopped. Would you like to view the error information?'

    And there is a Y/N prompt that does not do anything if you select Yes - just a blank IE window.

    What do I need to do??

     

    Thanks

    Rob

    Thursday, December 24, 2009 7:38 AM

All replies

  • User-1844410684 posted

    if your are using Crystal Report Viewer set he  property to 

     

     

    PrintMode="ActiveX" 


     

    Tuesday, December 29, 2009 7:11 AM
  • User-1946277446 posted

    No, this is via the Enterprise InfowViewApp 

    Tuesday, December 29, 2009 7:57 AM
  • User-1647178862 posted

    Hello!

    I've the same problem with Crystal .NET Runtime for VS 2010 SP1.

    I do as it is written in developer's guide:

    1) Set PrintMode to ActiveX;

    2) Change web.config:

      <configSections>
        <sectionGroup name="businessObjects">
          <sectionGroup name="crystalReports">
            <section name="printControl" type="System.Configuration.NameValueSectionHandler" />
          </sectionGroup>
        </sectionGroup>
      </configSections>
      <businessObjects>
        <crystalReports>
          <printControl>
            <add key="url" value="http://localhost/MyWebApp/PrintControl.cab" />
          </printControl>
        </crystalReports>
      </businessObjects>
    Environment: IIS 7, Windows 7, VS2010
     
    Monday, June 6, 2011 7:33 AM
  • User1196771204 posted

    hi basil2010,

    may I please know how did you host your crystal report? Do you host it on a shared server OR do you host it on your own server?

    If you are looking for a Crystal Report host, you can check out asphostcentral.com.


    Monday, June 6, 2011 11:09 PM
  • User-1647178862 posted

    Hello!

    I've found the problem.

    My web application is saves session in URL (sessionstate cookieless ="UseUri").

    I just use Crystal .NET Runtime for VS 2010. I host it on my own server.

    If I drill through HTML client code.

    I will see:

    bobj.crv.writeWidget({'cons':'bobj.crv.newViewer','args':{'id':'objCtrlCrystalReportViewer__UI','isDisplayModalBG':false,'visualStyle':{'className':'caBody','width':'1104px','height':'1202px'},'layoutType':'fitReport'},'children':[{'cons':'bobj.crv.newPrintUI','args':{'isActxPrinting':true,'codeBase':'../aspnet_client/system_web/4_0_30319/crystalreportviewers13/ActiveXControls/PrintControl.cab','url':'../MyWebApp/(S(43ldi5m4vt33atpiitubd1hd))/ToRunReport.aspx','paperOrientation':1,'paperSize':1,'paperWidth':0,'paperLength':0,'driverName':'Microsoft XPS Document Writer','useDefPrinter':false ...

    The reason is in invalid path to original aspx page "../MyWebApp/(S(43ldi5m4vt33atpiitubd1hd))/ToRunReport.aspx"

    It should be "../../MyWebApp/(S(43ldi5m4vt33atpiitubd1hd))/ToRunReport.aspx".

    Are there any limitations for Crystal Reports .NET Runtime for VS 2010 working with ASP .NET web applications which saves session ID in URL?

     

    Thursday, June 9, 2011 7:58 AM
  • User-295915200 posted

    could also occur if viewer is hosted in ajax update panel

    Tuesday, November 1, 2011 11:59 AM
  • User-1647178862 posted

    Hi,

    I've already post this question on SAP forum.

    They told me that it is a bug.

    But they didn't tell me when it I'll be fixed.

     

    See the link:

    http://forums.sdn.sap.com/thread.jspa?threadID=1981431&start=15&tstart=0

    Wednesday, November 2, 2011 2:53 AM
  • User1196771204 posted

    hi basil 2010,

    I recommend you to open a new thread to post this question. With a new thread, the other forum members may have a chance to response it.

    Thanks heaps! 

    Wednesday, November 2, 2011 4:51 AM