locked
Cannot create/shadow copy 'Microsoft.Practices.EnterpriseLibrary.Data' when that file already exists RRS feed

  • Question

  • User-192792487 posted
    Lately I am getting this error when compiling my application. Does anybody have an idea what is going wrong???<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p><o:p> </o:p>Cannot create/shadow copy 'Microsoft.Practices.EnterpriseLibrary.Data' when that file already exists.<o:p></o:p><o:p> </o:p>
    === Pre-bind state information ===<o:p></o:p>
    LOG: User = DREAMCATCHER\Bischi<o:p></o:p>
    LOG: DisplayName = Microsoft.Practices.EnterpriseLibrary.Data<o:p></o:p>
     Calling assembly : (Unknown).<o:p></o:p>
    ===<o:p></o:p>
    LOG: This bind starts in default load context.<o:p></o:p>
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.<o:p></o:p>
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).<o:p></o:p>
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/shareyourlossweb/887ea9ec/383e808e/Microsoft.Practices.EnterpriseLibrary.Data.DLL.<o:p></o:p>
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/shareyourlossweb/887ea9ec/383e808e/Microsoft.Practices.EnterpriseLibrary.Data/Microsoft.Practices.EnterpriseLibrary.Data.DLL.<o:p></o:p>
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.<o:p></o:p>
    LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).<o:p></o:p>
    ERR: Failed to complete setup of assembly (hr = 0x800700b7). Probing terminated.<o:p></o:p>
    Thursday, May 3, 2007 3:05 PM

All replies

  • User-189713343 posted

    Restart IIS.

    I have had same issue and it is fixed by restarting IIS

    Thursday, March 4, 2010 9:11 AM
  • User-37275327 posted

    Delete the existing reference and add again


    Saturday, March 6, 2010 9:49 PM