none
WCF Identity Editor in Endpoint Identity "Failed Authentication" RRS feed

  • Question

  • I am running BizTalk 2006 R2 in a Windows Server 2003 R2 SP2 environment.  I am calling a wcf service that does not have security.  It is using anonymous access and a basic http binding.  Consistently I am getting a fault message stating that authentication failed.  I think I have narrowed down this problem to the endpoint identity but I am new to biztalk and wcf and am not sure how to correctly configure this to ensure handshake success.  Some quick guidance would be appreciated.
    Adam
    Monday, April 27, 2009 5:47 PM

Answers

  • So you have a couple of options about how to transmit the credential information to authenticate with the IIS service hosting WCF. Even if anonymous access is enabled, if the Windows authentication checkbox is checked in IIS, the service will try to authenticate the BizTalk account.

    If you are using the WCF-BasicHttp adapter, then specify Transport for Security Mode and then for Transport Client Credential Type, choose the one that matches your security environment, probably NTLM or Windows. Basic sends in cleartext.

    If you are using the WCF-Custom adapter, then after you specify the basicHttp binding, and then specify Transport for Security Mode and then for Transport Client Credential Type, choose the one that matches your security environment, probably NTLM or Windows. Basic sends in cleartext.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Wednesday, April 29, 2009 4:26 AM
    Moderator