locked
Drag and Drop Control Not Working - IE 11 RRS feed

  • Question

  • A user with MS Office 2013 properly installed/configured and 32-bit Internet Explorer, is getting an "x" in place of drag & drop control while uploading files to SharePoint document library. What could be the problem?

    Any pointers?



    • Edited by diffident Wednesday, October 29, 2014 4:17 PM
    Tuesday, October 21, 2014 8:32 PM

All replies

  • I can user 32-bit IE to upload the documents using drag&drop control. To narrow down this issue, please try this on another computer with 64-bit IE, and try other browser like chrome to check whether the same scenario happens.

    would be better to attach a screenshot here to better understand this question.


    Qiao Wei <br/> My blog:http://blog.goobol.com

    Wednesday, October 22, 2014 1:51 AM
  • User is using Internet Explorer 11. I have attached all the relevant screenshots. I also asked him to check the following settings and attached is a response:

    ==================

    Option 1: From the Tools menu in the Internet Explorer (the "gear" icon) select Internet Options.

        Select the Security tab.
        Click Local Intranet as the zone to change.
        Click Custom Level. The Security Settings - Internet Zone dialog box appears.
        Scroll down to the options below Internet ActiveX Controls and Plugins and ensure the below options are enabled:
        1. Run ActiveX Controls and Plugins
        2. Script ActiveX Controls Marked Safe for Scripting


    Option 2: Launch Internet Explorer from: C:\Program Files (x86)\Internet Explorer\iexplore.exe
                      Does it work?

    Option 3: Ensure that the following DLLs are present:
                        C:\Program Files (x86)\Microsoft Office\Office14\STSUPLD.DLL
                        C:\Program Files (x86)\Microsoft Office\Office12\STSUPLD.DLL
                        C:\Program Files (x86)\Microsoft Office\Office11\STSUPLD.DLL

    =============

    Option 1: All Enabled

    Option 2: Not working

    Option 3: See below:

    Any thoughts or pointers?

    Wednesday, October 29, 2014 3:11 PM
  • This is what user sees in upload interface:

    Wednesday, October 29, 2014 3:12 PM
  • Hi,

    Try adding site as a trusted site (in your browser) and then try to upload


    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 3:45 PM
  • Already done but no luck
    Wednesday, October 29, 2014 3:49 PM
  • Did you try it from different browsers?


    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 3:57 PM
  • That is one of the things I am going to have the user try but I am looking for solutions so that he can use Internet Explorer because other browsers are not supported in our company.
    Wednesday, October 29, 2014 4:02 PM
  • Here are the possible causes and solutions:
      • Check whether You have not enable "Client Integration" in SharePoint
      • IE security setting may blocked the STSSYNC ActiveX add on - Enable it from "Manage Addons" in IE
      • This feature depends on Ms-Office, Check whether you have Office installed on the client. If you have it installed, Try running the office diagnostics or even try re-installing office
      • Disable the IE ESC if enabled!
      • Check the path of the folder in which you are trying to upload. It should not exceed the 256 character limit.

    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 4:07 PM
  • Checked all of them. No luck still...
    Wednesday, October 29, 2014 4:15 PM
  • Didi you check with I.E 10 or 9?

    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 4:40 PM
  • we do not have that option. Only IE 11.
    Wednesday, October 29, 2014 5:04 PM
  • Press F12, change the document mode to 10 and 9. Try if you can upload the documents


    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 5:09 PM
  • Did you also try the explorer view to drag and drop the files into Sharepoint


    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 5:30 PM
  • We do not expose explorer view to end users.
    Wednesday, October 29, 2014 10:04 PM
  • Qiao Wei - Any insights into this problem? I have provided all the screenshots.
    Thursday, October 30, 2014 4:18 PM
  • I know you posted this question to the SP 2013 forum, but just to make sure - are you using SP 2013 or SP 2010?

    David

    Thursday, October 30, 2014 5:26 PM
  • Hi Diffident

    Did you try in I.E 10 or 9 using document mode?


    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 5:45 PM
  • through your screen shot, it seems that you use SharePoint 2010.

    the multiple upload function needs STSUpld.UploadCtl, and it doesn't exists in your browser add-on, this may be the cause of the issue.

    you can check following document for more information:

    http://thuansoldier.net/?p=2289 


    Qiao Wei &lt;br/&gt; My blog:<a href="http://blog.goobol.com">http://blog.goobol.com</a>

    Friday, October 31, 2014 2:08 AM
  • Qiao - Even though it is SharePoint 2010, user has Office 2013 installed so should not the add-on be present already? How can I verify that?
    Friday, October 31, 2014 9:21 PM