none
Page will not load The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. access DB RRS feed

  • Question

  • Stack Trace: 

    [InvalidOperationException: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.]
       System.Data.OleDb.OleDbServicesWrapper.GetDataSource(OleDbConnectionString constr, DataSourceWrapper& datasrcWrapper) +1786494
       System.Data.OleDb.OleDbConnectionInternal..ctor(OleDbConnectionString constr, OleDbConnection connection) +1795286
       System.Data.OleDb.OleDbConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningObject) +100
       System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup) +43
       System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) +6352783
       System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) +6353246
       System.Data.OleDb.OleDbConnection.Open() +48
       System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +292
       System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior) +420
       System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, String srcTable) +312
       System.Web.UI.WebControls.SqlDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) +3422599
       System.Web.UI.WebControls.ListControl.OnDataBinding(EventArgs e) +188
       System.Web.UI.WebControls.ListControl.PerformSelect() +51
       System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +105
       System.Web.UI.WebControls.ListControl.OnPreRender(EventArgs e) +35
       System.Web.UI.Control.PreRenderRecursiveInternal() +113
       System.Web.UI.Control.PreRenderRecursiveInternal() +222
       System.Web.UI.Control.PreRenderRecursiveInternal() +222
       System.Web.UI.Control.PreRenderRecursiveInternal() +222
       System.Web.UI.Control.PreRenderRecursiveInternal() +222
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4201
    Monday, June 4, 2012 1:23 PM

Answers

  • Hi Wbennin,

    Welcome to the MSDN Forum.

    Is your server 64bit?

    If so, please try this KB: http://support.microsoft.com/kb/894435/en-us 

    and the key part is: 

    ASP.NET 1.1, 32-bit version

    To run the 32-bit version of ASP.NET 1.1, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
      cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    3. Type the following command to install the version of ASP.NET 1.1 and to install the script maps at the IIS root and under:
      %SYSTEMROOT%\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 1.1.4322 is set to Allowed in the Web service extension list in Internet Information Services Manager.

    ASP.NET 2.0, 32-bit version

    To run the 32-bit version of ASP.NET 2.0, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
      cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    3. Type the following command to install the version of ASP.NET 2.0 (32-bit) and to install the script maps at the IIS root and under:
      %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 2.0.50727 (32-bit) is set to Allowed in the Web service extension list in Internet Information Services Manager.

    I hope this will be helpful.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by wbennin Tuesday, June 5, 2012 8:08 PM
    Tuesday, June 5, 2012 9:01 AM
    Moderator

All replies

  • Hi, 

    Can you provide more details? like 

    your connection string

    Are you running application at 64- bit or 32- bit? Change at IIS app pool , allow running 32-bit applications.


    If this post answers your question, please click "Mark As Answer". If this post is helpful please click "Mark as Helpful".

    Monday, June 4, 2012 3:15 PM
  • Hi, Thanks for the response, I'm a bit new to that IIS side I just upload my project to an existing IIS server I was only given access to the wwwroot folder. also its my first time working with asp.net and and db working together. I was create an asp project. the default set was all CPUs than I changed it to 32bit when I debug and run locally it runs fine, in IE, I'm able to add entries to the db but once its up on the server. I get that error. I asked the admin to update the dlls and the access database engine.
    Monday, June 4, 2012 3:54 PM
  • Hi Wbennin,

    Welcome to the MSDN Forum.

    Is your server 64bit?

    If so, please try this KB: http://support.microsoft.com/kb/894435/en-us 

    and the key part is: 

    ASP.NET 1.1, 32-bit version

    To run the 32-bit version of ASP.NET 1.1, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
      cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    3. Type the following command to install the version of ASP.NET 1.1 and to install the script maps at the IIS root and under:
      %SYSTEMROOT%\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 1.1.4322 is set to Allowed in the Web service extension list in Internet Information Services Manager.

    ASP.NET 2.0, 32-bit version

    To run the 32-bit version of ASP.NET 2.0, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type the following command to enable the 32-bit mode:
      cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    3. Type the following command to install the version of ASP.NET 2.0 (32-bit) and to install the script maps at the IIS root and under:
      %SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
    4. Make sure that the status of ASP.NET version 2.0.50727 (32-bit) is set to Allowed in the Web service extension list in Internet Information Services Manager.

    I hope this will be helpful.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by wbennin Tuesday, June 5, 2012 8:08 PM
    Tuesday, June 5, 2012 9:01 AM
    Moderator
  • Hello Mike,

    Thanks for your followup, I had the server admin check out the info you provided and he made some changes. I did also find something in the web config file since our department uses a standard page the sitemaster and web config files were from past projects and I the connection string was forcing an sql connection. I removed that as well as the changes above and page loads fine

    Thank you all for your assistance

    • Marked as answer by wbennin Tuesday, June 5, 2012 8:08 PM
    • Unmarked as answer by wbennin Tuesday, June 5, 2012 8:08 PM
    Tuesday, June 5, 2012 8:08 PM
  • The original post here is corrupt (it goes out of the frame to the right) due to pasted in formatting and nesting (the native code block tool in the editor was not used).

    So could the OP/Asker (wbennin) or a mod (like Mike) please manually fix the formatting?

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)


    Friday, June 8, 2012 12:16 AM
    Owner