locked
Refresh browser and re-login to Azure Portal to SSH into a new Linux VM via Cloudshell RRS feed

  • Question

  • When we create a new Linux VM on Azure Portal (using UI), and try to connect/ssh to the new VM via Cloudshell/Bash Powershell, we cannot connect and the command "ssh user@vm-ip" just sits there forever.

    After trying several options, changing network settings on the VM, i found out that it is a simple browser refresh, clear cache, and re-login to Azure Portal did the trick. After that i was able to login.

    Let me explain:

    1. I created a CentOS Linux VM, was able to SSH into it using Bash on Cloudshell. So far so good.

    2. Then i deleted the CentOS VM, and created an Ubuntu VM. Same Azure portal session.. when i tried to SSH into it, i was not able to.

    3. After browser refresh, clear cache, re-login to Azure portal, i was able to. Actually now i'm presented with the option to create a new cloudshell which was not the case earlier.

    Create cloudshell option on new VM

    Successfully able to SSH into the new VM.


    Friday, February 2, 2018 4:03 PM

All replies

  • Glad you got it working. Thank you for the detailed steps.

    If you wish you could test this on different browser to see if you experience the same behavior.

    Checkout the following documentations for details on this topic:

    Limitations of Azure Cloud Shell
    Troubleshooting Azure Cloud Shell

    ---------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Friday, February 2, 2018 9:29 PM
    Owner