none
[SOLVED] Wince calibration issue after enabling Hive based registry???? RRS feed

  • Question

  • Hello Friends,

    As, I want calibration test only once and for that I have enabled Hive based registry settings from the catalog items. But very first time when I power on the board and proceed after calibration test then every thing works fine.......

    But after rest or cold boot some time touch works fine and some times it does not work fine... Shall I use set IMGNOCALIBRATION=1 with Hve based registry enabled or something else...?????


    Thursday, October 9, 2014 12:47 PM

All replies

  • Hello Friends,

    After power on I calibrate the board and open the Remote Reg File Editor and saw the saved calibration value under

    [HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

    and I saved it in notepad and reset the board and again i open the reg file editor and i saw the same value presist over there but the touch calibrate is not working fine. Some times it works fine and some time it does not work fine............

    It is confirmed that it is reading the value but after reading the value, touch is adding or subtracting in the existing values and that's why touch is not working fine.....

    The problem is related to touch line or something else........


    Thursday, October 9, 2014 3:08 PM
  • Hi Partap,

    Seems , It hasn't problem in hive and calibration value.

    I think it is problem in touch driver.

    if it is working means ,calibration is differ or touch is not response?

    Can you do calibration application in kiosk mode?

    You can test continuously.If it is not working ,problem in touch driver.

    Thanks

    With Regards

    Rajesh kannan


    Friday, October 10, 2014 6:37 AM
  • Hello There,

    If the issue is related to driver then it should not work for the very firs time....??????

    Friday, October 10, 2014 1:37 PM
  • Hello ,

    If it is change calibration touch value and restart the board .It is persist means Hive is proper.

    1)Whatever above test case with out hive test case.

    2)You can update calibrate value in platform.reg and test continuously.

    How will test with out hive calibration in touch?

    I have worked touch driver in WinCE .In my experience i updated ..

    If it is problem in GPIO irq, It will work some times.

    Thanks

    With Regards

    Rajesh Kannan


    Friday, October 10, 2014 4:44 PM
  • Hello,

    Hi, I am using Hive Calibration. So, the calibrated data is stored properly and I can see this by Reg Edit Remote tool under

    registry -

    HKEY_LOCAL_MACHINE/Hardware/DeviceMap/Touch

    Saturday, October 11, 2014 11:08 AM
  • Hi Partap,

    I didn't understand your issue.

    Can you explain your issue with your test case?

    Is it not working some time? or mismatching calibration value.

    You can copy calibrated value and update platform.reg.

    in the above test case with out hive test..

    Thanks,

    With Regards,

    Rajesh kannan


    Saturday, October 11, 2014 1:18 PM
  • Hi Rajesh,

    The tested values are as -


    Calibration(First Time Power One)
    2122,2105 976,1020 967,3216 3300,3227 3295,1015 

    Reset(Cold Reboot)
    2122,2105 976,1020 967,3216 3300,3227 3295,1015 
    2122,2105 976,1020 967,3216 3300,3227 3295,1015 

    But after reset or cold boot, the touch  does not work fine....

    Saturday, October 11, 2014 1:21 PM
  • Hi Partap,

    I understand your issue .

    Is it working power on and off ?

    Is it not working using restart and cold boot ?

    Please let me know .

    Thanks,

    With Regards

    Rajesh Kannan


    Saturday, October 11, 2014 4:11 PM
  • Hi Rajesh,

    It's only wrok fine very first time.

    1. No, it does not work fine after power on and off.

    2. No, it does not work fine after reset and cold boot.

    Monday, October 13, 2014 3:35 AM
  • Hi Partap,

    I have few doubt ,

    First time working fine means,following scenario is it correct?

    1)Power on the board.

    2)loaded WinCE

    3)Run calibration application using mouse or keyboard.

    4)you can access GUI using touch.

    5)power off the board .

    again power on the board .

    It is not working .

    How will recover again working condition ?

    Thanks,

    With Regards

    Rajesh Kannan

    Monday, October 13, 2014 5:25 AM
  • Hi Rajesh,

    1. Yes

    2. Yes.

    3. Testing the calibration test with Stylus

    4. I can access the GUI using touch.

    5. Yes

    6. Yes

    7.Its working but touch does not work accurately...

    8. But in the callibration data, the value is same each and every time ...

    Monday, October 13, 2014 5:38 AM
  • Partap:

    Look back at this thread and ask why you aren't getting further.  Rajesh has been trying diligently to figure out what your problem is. 

    I don't have any idea what you mean by "works fine" and "does not work fine".  Those are two of the worst problem definitions that I have ever seen.

    If you really want assistance, then take some time and describe the problem using real engineering terms.   Tell us what you see, tell us what you expect to see but don't see - but don't use the word fine.  Don't assume that we have the same expectations that you have, because we rarely, if ever, have the same expectations as you.

    Good luck.


    Bruce Eitman (eMVP) Senior Engineer Bruce.Eitman AT Eurotech DOT com My BLOG http://geekswithblogs.net/bruceeitman Eurotech Inc. www.Eurotech.com

    Monday, October 13, 2014 1:15 PM
    Moderator
  • Hello Friends,

    Hi Sir, I deeply apologize because I was not using technical terms.

    My issue that -

                   When I power on the board and the calibration test appears and I calibrate the screen for first time it store the value some where(touch screen .reg in Calibrate Data Key). When I start exploring the WINCE device with the help of touch it work fine. When I say it works fine then I mean that where I point on the screen with stylus it is accurate or to the point.....

                     But when I reset the board, and Wince desktop appears and again I start working with stylus, touch does not work fine; means where I touch on the screen it points to some where else instead of pointing to the same point. But that depends. Some times with reset touch is 100% accurate, some time 95% accurate and some times 80-90% accurate.

    Each and every time when I see the Calibrate Data value in .reg file over KITL. It is same.....

    So,  upto so far what we conculde here, the problem may be related to H/W because the same touch is not accurate in Linux. But we have another LVDs and on that touch is working accurate each and every time...

    If you are thinking some thing else then please share so that we can close the issue ...???????


    Tuesday, October 14, 2014 4:13 AM
  • Partap:

    That was much better.  It looks like a hardware problem, but you can and should verify using engineering methods, like:

    1. Use a larger sample size
    2. Use a scope to measure hardware analog signals
    3. Add debug code to output raw touch readings


    Bruce Eitman (eMVP) Senior Engineer Bruce.Eitman AT Eurotech DOT com My BLOG http://geekswithblogs.net/bruceeitman Eurotech Inc. www.Eurotech.com

    Wednesday, October 15, 2014 1:29 PM
    Moderator
  • Hello Friends,

    Hi Sir,

    Now, its confirmed from Our side the particular problem is related to H/W only. As, much the LCD is Chinese low quality LCD and we have tested the same with our standard German based LCD...... Its ok with good quality LCD....

    By the way thanks for efforts......

    Thursday, October 16, 2014 11:30 AM