locked
BizTalk 2013 SFTP Adapter - Unable to pull files from SFTP server RRS feed

  • Question

  • Hi All,

    We have this BizTalk OOB SFTP receive location that is configured to access the clients SFTP server using a private key protected with a password. Recently the client decided to upgrade their server and updated their Server host key as well.

    Since the receive location property "AcceptAnySSHServerHostKey" is set to "True" it will accept the new server host key. However, no files are able to be pulled from the server. No errors/warnings/info on the event logs can be seen and the receive location is on.

    Our existing winSCP session still works as usual and we still can read/write/delete from the directory.

    Would it be possible that it may be due to the server upgrade as well? I recall the BizTalk OOB adapter having problems with later versions of ubuntu.

    New SFTP server: Openssh - openssh-7.4p1-16.el7.x86_64 on RHEL 7.6

    Old SFTP server: openssh-server-4.3p2-82.el5 on RHEL 5

    Thanks

    Wednesday, November 28, 2018 2:54 AM

All replies

  • I've had issues with the OOB SFTP adapter having connections issues, but it does raise an error.

    What CU are you on? There have been some fixes for the SFTP adapter, e.g.  FIX: BizTalk Server 2013 SFTP adapter doesn't pick up files from the SFTP server in CU 3

    Wednesday, November 28, 2018 3:14 AM
  • Hi,

    Requesting you to try configuring the same SFTP URL with new receive port/location and see if you still getting the same behaviour.

    Also for your existing Receive Location have you tried to Disable Receive Location > Restart Associated BizTalk Host Instance > Enable Receive Location

    HTH


    Hope this Helps!!!! Regards, Note: Please Mark As Answered if you satisfy with Reply.

    Wednesday, November 28, 2018 8:12 AM
  • We have installed the following CU/hotfixes for BizTalk 2013

    Microsoft BizTalk Server 2013 CU2 [KB 2892599]LDR

    Microsoft BizTalk Server 2013 Hotfix for KB 29009928

    We will review on installing CU3 and see how that goes.

    Thanks

    Wednesday, November 28, 2018 7:13 PM
  • We have not tried setting up a new Receive port/location , but will give this a try.

    For the existing location, yes , we did follow the same restart steps but no luck.

    Thanks

    Wednesday, November 28, 2018 7:34 PM
  • You should consider installing the latest CU listed on this page Service Pack and cumulative update list for BizTalk Server, which for BizTalk 2013 is CU 7.  This will include all the fixes in the previous Cumulative Updates (hence they are called Cumulative).    If are not on the latest CU and try to raise a support ticket with Microsoft, the first thing they will ask you to do is apply the latest CU.
    Wednesday, November 28, 2018 7:42 PM