changing the RunAs account without reinstalling Workflow Manger RRS feed

  • Question

  • For SharePoint 2013 installation, I need to change the RunAs account.

    is it possible to change the RunAs account without reinstalling Workflow Manger/SB Manager without complete uninstall? Even if I remove all servers from the farm, seems like the RunAs account is always in Management db, so RunAs account is pre-populated with the old account.

    Thank you

    Monday, March 17, 2014 3:00 AM


All replies

  • I need to change the RunAs account as well.  Is reinstalling Workflow Manager and/or Service Bus the only option?  There is no powershell that changes the account?
    Monday, March 24, 2014 8:13 PM
  • To change the RunAs account of the Service Bus, use following PowerShell commands:

    Set-SBFarm -RunAsAccount Domain\Username
    $RunAsPassword = ConvertTo-SecureString -AsPlainText -Force '<password>'
    [RunOnAllNodes] Update-SBHost -RunAsPassword $RunAsPassword


    Then open the Service Control Manager and navigate to Workflow Backend Service and change manually the account.
    Restart the Wf Service.

    Damir Dobric

    • Marked as answer by KaliBaba Tuesday, April 8, 2014 6:00 PM
    Monday, April 7, 2014 11:27 PM
  • Thanks for that
    • Marked as answer by KaliBaba Tuesday, April 8, 2014 6:01 PM
    Tuesday, April 8, 2014 12:14 PM
  • Could you please be so kind and close the case.

    Thanks :)

    Damir Dobric

    • Marked as answer by KaliBaba Tuesday, April 8, 2014 6:00 PM
    Tuesday, April 8, 2014 4:46 PM
  • I marked it as answer assuming this closes the thread, I don't see any other option
    Tuesday, April 8, 2014 6:01 PM
  • I'm getting:

    "Set-SBFarm : The term 'Set-SBFarm' is not recognized as the name of a cmdlet,

    function, script file, or operable program. Check the spelling of the name, or
    if a path was included, verify that the path is correct and try again.
    At line:1 char:1
    + Set-SBFarm -RunAsAccount XXX\XXXX
    + ~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Set-SBFarm:String) [], CommandN
        + FullyQualifiedErrorId : CommandNotFoundException"

    I have Service Bus 1.0, the one that WF installs and I'm running this from the Service Bus Powershell.


    Monday, August 18, 2014 12:28 AM
  • you need to start command from WorkflowManager powershell and not fron default powershell environment.

    Damir Dobric

    Monday, August 18, 2014 7:42 AM
  • Hi Damir, I am getting too "Set-SBFarm : The term 'Set-SBFarm' is not recognized as the name of a cmdlet,

    I already try to get the Set-sbfarm from the workflow manager powershell and I get the same error, already try too form the servicebus powershell.

    Thanks for the help!

    Monday, September 8, 2014 6:21 AM
  • Hi

    Coincidently,  I also need to change the Run-as Account a Workflow Manager installation and yes I also I can't see Set-SBFarm either.

    Below shows the output when I ran Get-SBFarm followed by Set-SBFarm - The first command works as you can see but the second command....

    Is there a SP1  ( or even a CU) we need to apply e.g.  Cumulative Update 2 for Workflow Manager 1.0 (KB 2902007?

    Also, what is the the "Service Control Manager" as  doesn't  appear as one of the two installs added to  my apps in win2012r2.


    Freelance consultant

    Wednesday, October 15, 2014 1:21 PM
  • In my case I had to reinstall because when I initially uninstalled it I uninstalled the SB service first. The order of uninstallation matters
    Thursday, October 16, 2014 12:37 AM
  • KaliBaba, were you able to solve this issue? We are in the same situation, and we have run the commands pointed out by Damir. It changed Service Bus runas account and password, but it doesn't change workflow runas account. We tried to go to Services, and manually changed the Workflow Manager Backend service's account, as well as IIS's application pool account. But workflow still has authentication issues when it communicates with Service Bus. Also when running the following command (without any parameters so it displays the current configuratoin):


    We see the workflow runas account is still the original account, even though Workflow Manager Backend service's account is already the new one. This command allows us to update the runas account's password, but it doesn't allow us to change the account.

    Now anything depending on the workflow, such as SharePoint, have stopped working. Has anyone been able to solve the problem?

    Thursday, July 2, 2015 3:34 AM
  • I'm having the same issue whenever I try to run the command it says:

    Set-SBFarm : The term 'Set-SBFarm' is not recognized as the name of a cmdlet

    I have tried executing it from Workflow powershell and Sahrepoint Admin powershell, same result in both.

    Has anyone found a solution for this? Thanks.

    Friday, January 29, 2016 9:57 PM
  • AFIK, you can change RunAs account through Set-SBFarm cmdlet only on SB 1.1. It could be the reason for not finding cmdlet on SB 1.0. There is no cmdlet for changing RunAs account in WFM. There is a workaround which can try in your test env before applying in Prod.

    1)      Change RunAs account in ClusterConfig table of WFManagement Db.
    2)      Run AddUserToServiceOperators Stored Proc in WfResourceManagement Db with new RunAs account name as argument.

    3)  Remove each node from the farm and join it back one at a time. 

    There is a similar workaround exist for changing RunAS account in SB 1.0. Otherwise you can upgrade SB to 1.1 and use Set-SBFarm command.

    • Proposed as answer by admin5467 Tuesday, June 18, 2019 1:10 PM
    • Unproposed as answer by admin5467 Tuesday, June 18, 2019 1:11 PM
    Saturday, January 30, 2016 2:42 AM
  • Step 1 - Stop-SBFarm

    Step 2 - Set-SBFarm with new Domaind\NewAdmnGroup

    Step 3 - Update-SBHost

    Step 4 - Start-SBFarm

    Step 5 - Confirm Domaind\NewAdmnGroup has been updated

    Run PowerShell as Farm Admin


    Set-SBFarm -AdminGroup "Domaind\NewAdmnGroup" -SPWFMAdmins"
    Start-SBFarm ##Start the Service Bus Farm. This can take a while.

    • Edited by admin5467 Tuesday, June 18, 2019 1:31 PM
    Tuesday, June 18, 2019 1:11 PM