locked
need a help! Windows 10 problem with Framework 4.0 C:\Windows\Microsoft.NET\Framework\v4.0.30319\crl.dll 0xc0000020 RRS feed

  • Question

  • Hi everybody! Need a help with Framework 4.0. The problem appears with instalation some desktop programms. I have Windows 10 Home and Framework 4.6.  C:\Windows\Microsoft.NET\Framework\v4.0.30319\crl.dll 0xc0000020
    Saturday, March 5, 2016 9:18 AM

Answers

  • Hi, Kristin

    I know that Framework 4.0 is included to Framework 4.6, but the programm required a Framework 4.0, I don't know why. I tried the first step but it was unsuccessful. I even have made system reset twice, but the problem was not disapeared. there is a picture https://drive.google.com/file/d/0B5p-1nsXpmphai1HTENqY2x4dms/view?usp=sharing

    Hi,

    I am sorry, this is English forum, I cannot understand what does the picture means.

    For a better support, you could use the russian CLR  forum https://social.msdn.microsoft.com/Forums/vstudio/ru-RU/home?forum=clr

    In addition, please try to uninstall all .net framework 4.6 and 4.5, then install .net 4.0 again.

    Do you have a try?

    If you meet some installation issue, please post in win10 community forum for better support.

    .NET Framework supports backward compatibility. Backward compatibility means that an app that was developed for a particular version of a platform will run on later versions of that platform. So if you run an app that target 4.0 should be works fine on win10 that has 4.6 installed.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Kristin Xie Tuesday, March 8, 2016 6:03 AM
    • Marked as answer by gabe.moore Friday, March 11, 2016 2:26 PM
    Tuesday, March 8, 2016 6:00 AM

All replies

  • Hello,

    sry but I don't understand your problem. Can you pls post more infos, what did you, what need you...

    Regards...

    Duris_I

    Saturday, March 5, 2016 11:50 AM
  • Hi,

    Do you mean you want to install .Net framework in win10? If yes,

    Due to Win10 OS  has been integrated. NET Framework 4.6 defiantly and it  is backward-compatible, we no longer need to install. NET Framework 4.0.

    If you are running some software needs. NET Framework 4.0, you can try Win10 "Turn Windows features on or off" uncheck the. NET Framework 4.6 and installed again.

    You also could check in registry

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client

    This stands for the current version in win10 os.

    If I misunderstood you, please feel free to let me know.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Monday, March 7, 2016 5:54 AM
  • Hi, Duris

    there is a link with screen of my problem (mdsn doesn't let me to send a picture)

    https://drive.google.com/file/d/0B5p-1nsXpmphai1HTENqY2x4dms/view?usp=sharing

    Monday, March 7, 2016 10:09 AM
  • Hi, Kristin

    I know that Framework 4.0 is included to Framework 4.6, but the programm required a Framework 4.0, I don't know why. I tried the first step but it was unsuccessful. I even have made system reset twice, but the problem was not disapeared. there is a picture https://drive.google.com/file/d/0B5p-1nsXpmphai1HTENqY2x4dms/view?usp=sharing

    Monday, March 7, 2016 10:18 AM
  • Hello,

    via that message it looks like there is something missing. Did you install from original media (look at message)? Message stay about needed reinstall of your application, did you try it?

    Edit: don't super understand russian, but also that message isn't so clear to me. You must know what you do, if you're doing correct things...

    Regards...

    Duris_I

    • Proposed as answer by Duris_I Friday, March 11, 2016 2:01 PM
    Monday, March 7, 2016 11:36 AM
  • Hi, Kristin

    I know that Framework 4.0 is included to Framework 4.6, but the programm required a Framework 4.0, I don't know why. I tried the first step but it was unsuccessful. I even have made system reset twice, but the problem was not disapeared. there is a picture https://drive.google.com/file/d/0B5p-1nsXpmphai1HTENqY2x4dms/view?usp=sharing

    Hi,

    I am sorry, this is English forum, I cannot understand what does the picture means.

    For a better support, you could use the russian CLR  forum https://social.msdn.microsoft.com/Forums/vstudio/ru-RU/home?forum=clr

    In addition, please try to uninstall all .net framework 4.6 and 4.5, then install .net 4.0 again.

    Do you have a try?

    If you meet some installation issue, please post in win10 community forum for better support.

    .NET Framework supports backward compatibility. Backward compatibility means that an app that was developed for a particular version of a platform will run on later versions of that platform. So if you run an app that target 4.0 should be works fine on win10 that has 4.6 installed.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Kristin Xie Tuesday, March 8, 2016 6:03 AM
    • Marked as answer by gabe.moore Friday, March 11, 2016 2:26 PM
    Tuesday, March 8, 2016 6:00 AM
  • Thank you
    Tuesday, March 8, 2016 5:56 PM
  • Thank you
    Tuesday, March 8, 2016 5:56 PM
  • Hi gabe,

    Please remember to close this thread by marking helpful reply as an answer, thanks for your cooperation and support.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 9, 2016 1:33 AM