none
.NET Framework doesn't work. Can't find/install/uninstall RRS feed

  • Question

  • Hello,

    I'm sorry if it doesn't belong here, I have no idea where to ask this.

    I own a HP ProBook 4740s with Windows 8 and a week ago, I started receiving errors on startup. CLI.exe and MOM.exe NET Framework Initialization Errors. Both with message ''to run this application you first must install one of the following versions of the .net framework v4.0''. I am aware that both are related to Catalyst Control Center. Later, I got the same error message when I tried to play one of my games. Obviously I downloaded .NET Framework v4.0 and tried to install it to fix those problems, but the installer immediately stoped and said that there is same or higher version of .net framework already installed. I tried to uninstall it, so I can re-install it again with the correct version, but I couldn't find .NET Framework in Control Panel's Programs and Features and when I downloaded and used Framework cleanup tool it did nothing. I also tried installing version 4.5 but I got Same or higher version of .Net Framework has already been installed on this computer error message again. So when I can't install it nor uninstall it, what can I do? Thanks for your help

    Tuesday, August 5, 2014 4:44 PM

Answers

  • Hi,

    >>when I downloaded and used Framework cleanup tool it did nothing

    Could you please clarify the “nothing”? Do you mean the cleanup tool can’t uninstall .NET Framework?

    >> I couldn't find .NET Framework in Control Panel's Programs and Features

    The built-in .NET Framework can be found in the Windows Feature dialog. In Control Panel, choose “Programs and Features”, choose “Turn Windows features on or off”.

    >> I got the same error message when I tried to play one of my games

    Does this issue only occur on one Game? If yes, I guess this may also related with this Game. You can consult the vendor of this Game if others have the same issue.

    As you might know, Windows 8 has the .NET Framework 4.5 built-in and you can optionally activate. You can try to active the .NET Framework 4.0.

    If it can’t work, I suspect that there is something wrong with your system.

    Please open the command prompt as administrator then type sfc /scannow to repair the system file first.

    Second use setup verify tool to check the .NET installed status.

    .NET Framework Setup Verification Tool User's Guide:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Then use .NET Framework Repair Tool to fix some frequently occurring issues with the setup of Microsoft .NET Framework or with updates to the Microsoft .NET Framework.

    How to get the tool : http://www.microsoft.com/en-us/download/details.aspx?id=30135

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Anna Cc Sunday, August 17, 2014 3:49 AM
    Wednesday, August 6, 2014 8:30 AM