locked
I cannot deploy my LightSwitch app to my desktop PC RRS feed

  • Question

  • I written a LightSwitch app, my first. I wrote it using VS 2013 on my laptop. I want to deploy it to my desktop. It's a web app and I've already got IIS running on it. (Both my laptop and my desktop are running Windows 8.1 Professional.) Now, I've already installed Web Deploy on my desktop, so I think it's there, but not entirely sure. When I ran the Web Platform Installer 5.0 on my desktop, selecting Web Deploy, I got the following error message:

    I really don't know what to do about this, since the Web Platform Installer 5.0 is the one that's trying to access that .XML file, and it can't. I've tried doing this twice, different days, with the exact same result.

    Furthermore, and this may be related to the above problem/error, when I do try to deploy from VS 2013 on my laptop to my desktop, it gives an ERROR_DESTINATION_NOT_REACHABLE and says that I should make sure that Web Deploy is installed. It looks like it is, because when I get into the Web Platform Installer 5.0 (and get past the first error I listed above), then I see that it is installed. However, that error message in VS also says that I need to make sure that the process "Web Deployment Agent Service" is started. I assume by "process" in this case they mean Windows service, so I got into the Services applet on my desktop and found that there isn't even a service there named "Web Deployment Agent Service".

    Bottom line: I believe the root of the problem is with that initial error that I got trying to run the Web Platform Installer 5.0 and it's not being able to find some ProductID PHP. So how do I fix this problem so I can get done what I'm trying to get done?


    Rod

    Saturday, December 6, 2014 6:23 PM

Answers

  • Rod, did you solve?

    Sure there's something wrong in your very basic IIS configuration but I'd suggest not to follow standard WPI route. Have you checked in the posted link all details about turning on manually windows features?

    I should start checking something in the IIS Manager panel, from Computer Management:

    • Can you see 'Default Web Site' node under your PC name (IIS main node)?
    • Check in 'Authentication' in IIS section (Features View) if Anonymous Authentication is enabled, both at main level and at 'Default Web Site' level
    • Right click and edit on 'Anonymous Authentication' and check if identity is set as Specific user or Application pool identity
    • Right Click/Edit Permissions on 'Default Web Site' node and check in Security tab if IIS_IUSRS has Read&execute, List folder contents and Read permissions on the default folder (C:\inetpub\wwwroot)
    • Click 'Application Pools' node and check visible pools attributes and status

    Let us know


    Marco


    • Edited by technetcolmar Tuesday, December 16, 2014 7:10 AM (integration)
    • Proposed as answer by Angie Xu Monday, January 5, 2015 12:32 PM
    • Marked as answer by Angie Xu Wednesday, January 7, 2015 1:04 PM
    Tuesday, December 16, 2014 7:03 AM

All replies

  • Hi Rod, maybe you can take a look to one of my recent questions in this forum.

    My situation was different because I was publishing on the development box itself (Win 8.1 Pro), additionally I had no errors running WPI, but I think some info and links could be useful.

    Particularly consider this Dave Kidder words:

    The Server Configuration WPI feed doesn't work correctly on client OS's, you will need to manually configure IIS.

    and my words:

    I was assuming that, as per Beth's article, Web Deployment Agent Service was always needed so I installed it going in Control Panel - Programs and clicking Change on Web Deploy 3.5 to add 'Remote Agent Service'. Lately discovered that wasn't necessary.

    But it wasn't necessary *to me* just because I wasn't publishing remotely, about this Dave confirmed:

    You don't need the WebDeploy Remote Agent Service if you are deploying locally because the local WebDeploy install can do everything without making HTTP requests (which is what the Remote Service listens for).

    Link to the post for every detail

    Hope this helps.


    Marco

    Sunday, December 7, 2014 3:06 PM
  • Hello Marco,

    This is helpful. Indeed very helpful. But I wonder about that error message I get when I try running the Web Platform Installer? It seems as though whatever that is, it is getting in the way of my proceeding to deploy my web based LightSwitch app from my laptop to my desktop. I'll continue to go through the posting you referenced and Beth Massi's that's linked to it from the link you posted.


    Rod

    Tuesday, December 9, 2014 10:00 PM
  • Another thing; I've found that I cannot browse to http://localhost on my desktop box. Don't know why, but I can't. According to Beth Massi's post, that needs to be resolved before I can successfully deploy a LightSwitch app to my desktop PC.

    I'm getting a 401.3 error when I try to browse to http://localhost.


    Rod


    • Edited by Doctor-Who Tuesday, December 9, 2014 10:17 PM Needed to add some info
    Tuesday, December 9, 2014 10:16 PM
  • something wrong with your iis config,

    http://msdn.microsoft.com/en-us/library/gg481779.aspx

    Tuesday, December 16, 2014 2:34 AM
  • Rod, did you solve?

    Sure there's something wrong in your very basic IIS configuration but I'd suggest not to follow standard WPI route. Have you checked in the posted link all details about turning on manually windows features?

    I should start checking something in the IIS Manager panel, from Computer Management:

    • Can you see 'Default Web Site' node under your PC name (IIS main node)?
    • Check in 'Authentication' in IIS section (Features View) if Anonymous Authentication is enabled, both at main level and at 'Default Web Site' level
    • Right click and edit on 'Anonymous Authentication' and check if identity is set as Specific user or Application pool identity
    • Right Click/Edit Permissions on 'Default Web Site' node and check in Security tab if IIS_IUSRS has Read&execute, List folder contents and Read permissions on the default folder (C:\inetpub\wwwroot)
    • Click 'Application Pools' node and check visible pools attributes and status

    Let us know


    Marco


    • Edited by technetcolmar Tuesday, December 16, 2014 7:10 AM (integration)
    • Proposed as answer by Angie Xu Monday, January 5, 2015 12:32 PM
    • Marked as answer by Angie Xu Wednesday, January 7, 2015 1:04 PM
    Tuesday, December 16, 2014 7:03 AM