none
Unable to download connect.rdp from windows.azure.com.

    Question

  • I cannot remote into my instance of of my web deployment.  I click on the connect Icon and get the following error.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Unable to download connect.rdp from windows.azure.com.

    Unable to open this Internet site. The requested site is either unavailable or cannot be found.
    Please try again later.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    I have generated a cert and uploaded it to my Hosted Service.

    How much later? Is there something wrong in the way I am deploying? Is there another way to download or create the rdp file? Any help would be much appreciated. 

     

    Saturday, March 5, 2011 1:54 PM

Answers

  • Mog,

    I was able to download the rdp file from another desktop - the 3rd one I tried. 

    Thanks!

    • Marked as answer by Mog Liang Friday, March 11, 2011 8:47 AM
    Wednesday, March 9, 2011 1:57 AM

All replies

  • Hi Folkware,

    I doubt if the problem is related to your browser or your network. Have you tried on any other computer?

    Besides, you may try creating .rdp file by yourself.  the rdp format may like this:

    full address:s:[yourservicenamespace].cloudapp.net
    LoadBalanceInfo:s:Cookie: mstshash=[rolename]#[roleInstanceName]#Microsoft.WindowsAzure.Plugins.RemoteAccess.Rdp

     


    Mog Liang
    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Monday, March 7, 2011 3:17 AM
  • Mog,

    I was able to download the rdp file from another desktop - the 3rd one I tried. 

    Thanks!

    • Marked as answer by Mog Liang Friday, March 11, 2011 8:47 AM
    Wednesday, March 9, 2011 1:57 AM
  • Actually the problem was VERY likely the browser and it's security settings.

    On Windows 2008 R2 by default IE ESC is turned on which prevents the ability to make a download.  We saw that using FireFox the issue went away on a machine.  Once FireFox was used the machine no longer had the issue.  So on another computer I turned off ESC and didn't have the issue since the download was allowed to occur.  Here are the steps I took to fix the issue for us in Windows 2008 R2

    1. 1. Start --> Administrative Tools --> Server Manger
    2. 2. Highlight Server Manager(<ComputerName>) and click Confgured IE ESC in the Security Information section
    3. 3. Click the off radio button for the desire group either Administrators or Users

    Once you have complete the task of using RDP the first time you can turn the feature back on.  You may be requested to add the azure.com domain in the sercurity settings of IE, but you should be good to go that this point.



    Thursday, March 1, 2012 2:35 PM