locked
submitting also 8.1 package to existing win10 app RRS feed

  • Question

  • Hello, 

    I have in the store a win10 app (version = 1.0.0.0), now I what to add a package that supports also 8.1 phone and windows

    But I get this message:

    Appx packages (including previously published and currently uploaded) must be uniquely identified by their full names. The package full names PFN=14509YoavFael-YOANNA.ZodiacSignsandDailyHoroscope_rngc42z3h60hm,ResourceId=,Version=1.0.0.0,Architecture=Unknown and PFN=14509YoavFael-YOANNA.ZodiacSignsandDailyHoroscope_rngc42z3h60hm,ResourceId=,Version=1.0.0.0,Architecture=Neutral are too close to, or are overlapping with one another. Please remove one of these packages, or increment current package versions to continue.

    how can I fix this? 

    Thanks

    Wednesday, February 24, 2016 1:04 PM

All replies

  • The docs here state:

    The version number of your Windows 10 packages must be higher than those for any Windows 8, Windows 8.1, and/or Windows Phone 8.1 packages you are publishing (or packages for those OS versions that you have previously published) for the same app

    I guess you would need to bump up your win10 app version high enough to allow updates to the older packages.


    http://peted.azurewebsites.net/

    Wednesday, February 24, 2016 5:34 PM
  • Hi, Thank you for the response.

    I tried doing that but it's not working, I guess that it's because they have a problem even with previously published versions:

    Phone 8.1 packages you are publishing (or packages for those OS versions that you have previously published)"

    Do you know a way to go around that?


    Thursday, February 25, 2016 1:12 PM