locked
Visual Studio 11 Beta Crash when create or open a JavaScript Metro application

    Question

  • Maybe I'm unlucky in programming Windows Metro application. Everytime I create a JavaScript Blank application, the Visual Studio 11 Beta crash, and another processes take most of  CPU usage everytime, they are:

    - Service and Controller app

    - ServiceHost: Windows Error Reporting


      I almost can not do anything after opening VS11 Beta and lauching an JavaScript app.

    Any solution?

    Monday, March 19, 2012 12:18 AM

All replies

  • Can you please provide the event logs for when this happens?  It will help us to potentially identify what is happening on your machine when you try to create the project.

    Right-click on Computer, select Manage.  In the Computer Management console, expand Event Viewer, Windows Logs, and click on Application.  Please copy/paste the event logs that are written at the time of your crash (there are usually two associated with the crash).

    Also, please check if an activity log was generated from Visual Studio 11 Beta.  If it exists, it would be at [SYSTEMDRIVE]\Users\[YOURUSERNAME]\AppData\Roaming\Microsoft\VisualStudio\11.0\ActivityLog.xml

    Thanks,

    Gearard


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, March 19, 2012 4:06 PM
  • There are two error on event logs:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Windows Error Reporting" /> 
      <EventID Qualifiers="0">1001</EventID> 
      <Level>4</Level> 
      <Task>0</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2012-03-19T16:29:52.000000000Z" /> 
      <EventRecordID>2364</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>tumivn-laptop</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data /> 
      <Data>0</Data> 
      <Data>AppHangB1</Data> 
      <Data>Not available</Data> 
      <Data>0</Data> 
      <Data>devenv.exe</Data> 
      <Data>11.0.50214.1</Data> 
      <Data>4f3a3e10</Data> 
      <Data>f629</Data> 
      <Data>135168</Data> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data>C:\Users\tumivn\AppData\Local\Temp\WERF603.tmp.version.xml C:\Users\tumivn\AppData\Local\Temp\WERF6CF.tmp.xml C:\Users\tumivn\AppData\Local\Temp\WERF70F.tmp.WERInternalMetadata.xml C:\Users\tumivn\AppData\Local\Temp\WER1101.tmp.WERDataCollectionFailure.txt</Data> 
      <Data>C:\Users\tumivn\AppData\Local\Microsoft\Windows\WER\ReportQueue\Critical_devenv.exe_522f43db4882e16b7d4d4c491e67b63afa6c3e_cab_f096112c</Data> 
      <Data /> 
      <Data>0</Data> 
      <Data>bbeaa3a6-71e0-11e1-8801-f04da259b4ff</Data> 
      <Data>131092</Data> 
      <Data /> 
      </EventData>
      </Event>


    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Windows Error Reporting" /> 
      <EventID Qualifiers="0">1001</EventID> 
      <Level>4</Level> 
      <Task>0</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2012-03-19T16:29:55.000000000Z" /> 
      <EventRecordID>2365</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>tumivn-laptop</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>-1442571690</Data> 
      <Data>5</Data> 
      <Data>AppHangB1</Data> 
      <Data>Not available</Data> 
      <Data>0</Data> 
      <Data>devenv.exe</Data> 
      <Data>11.0.50214.1</Data> 
      <Data>4f3a3e10</Data> 
      <Data>f629</Data> 
      <Data>135168</Data> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data /> 
      <Data>C:\Users\tumivn\AppData\Local\Temp\WERF603.tmp.version.xml C:\Users\tumivn\AppData\Local\Temp\WERF6CF.tmp.xml C:\Users\tumivn\AppData\Local\Temp\WERF70F.tmp.WERInternalMetadata.xml C:\Users\tumivn\AppData\Local\Temp\WER1101.tmp.WERDataCollectionFailure.txt</Data> 
      <Data>C:\Users\tumivn\AppData\Local\Microsoft\Windows\WER\ReportArchive\Critical_devenv.exe_522f43db4882e16b7d4d4c491e67b63afa6c3e_f5e61e3c</Data> 
      <Data /> 
      <Data>0</Data> 
      <Data>bbeaa3a6-71e0-11e1-8801-f04da259b4ff</Data> 
      <Data>16</Data> 
      <Data>0570ebc697fc2acf864df0010e0e00f8</Data> 
      </EventData>
      </Event>

    The ActivityLog.xml isn't exist.

    Thanks!

    Dung H Le

    Monday, March 19, 2012 4:40 PM
  • Thanks.  Is there also an entry in the Event Viewer after these messages from source Windows Error Reporting that has text that contains "Fault bucket.."?

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, March 19, 2012 5:07 PM