locked
Can no longer preview ASP JavaScript database pages RRS feed

  • Question

  • User1638880958 posted
    Using DW MX 2004 with IIS 7 on home PC (Vista).  IIS language setting for ASP has always been VBScript.  All has worked well for a very long time, but for the past week or so, I have not been able to preview my ASP JavaScript database pages.  They upload fine to the remote server; just can't preview on localhost.  I get the following browser error:
    Active Server Pages error 'ASP 0129'
     
    Unknown scripting language
     
    /folder/file.asp, line 1
     
    The scripting language 'JAVASCRIPT' is not found on the server.
    Other ASP JavaScript pages preview fine, just not those with a database.  I've been searching endlessly for possible answers.  Recent computer changes include a downloaded trial version of Dreamweaver CS4 to an external drive and a 2008 uninstall/2009 install of McAfee.  I have since uninstalled CS4 and did major computer clean-up to see if that was it.  Nothing.
     
    I'm extremely frustrated and afraid I may have to rebuild my pages using ASP VBScript - no biggy, but why when all has been well up until now?  Any help is appreciated.
     
     
    Wednesday, February 4, 2009 6:17 PM

Answers

  • User1638880958 posted

    Yes. I tried changing VBScript in IIS to JScript.  I also tried changing line 1 in my file - LANGUAGE="JAVASCRIPT" - to VBScript. Nothing worked. 

    I have two computers, and the other computer previews fine. 

    On my main computer, I use MX 2004, but I recently downloaded a trial version of CS4 onto an external drive, not thinking at the time that all sorts of internal windows files including dlls might be overwritten.  So I'm wondering if MX 2004 got jolted somehow. I have since uninstalled CS4. But I may have to reinstall or try to "fix" MX 2004.

    I was told that "support for Javascript was removed from DW, but could be mistaken."
    If this is true and CS4 did something to remove that support, that might answer the problem.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, February 5, 2009 3:50 PM

All replies

  • User1073881637 posted

    I don't have vista loaded, so I can't verify but have you tried JScript instead of JavaScript?

    Thursday, February 5, 2009 12:51 PM
  • User1638880958 posted

    Yes. I tried changing VBScript in IIS to JScript.  I also tried changing line 1 in my file - LANGUAGE="JAVASCRIPT" - to VBScript. Nothing worked. 

    I have two computers, and the other computer previews fine. 

    On my main computer, I use MX 2004, but I recently downloaded a trial version of CS4 onto an external drive, not thinking at the time that all sorts of internal windows files including dlls might be overwritten.  So I'm wondering if MX 2004 got jolted somehow. I have since uninstalled CS4. But I may have to reinstall or try to "fix" MX 2004.

    I was told that "support for Javascript was removed from DW, but could be mistaken."
    If this is true and CS4 did something to remove that support, that might answer the problem.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, February 5, 2009 3:50 PM
  • User-965497187 posted

    Nicely, Put I am having the same problem...

    Armando

    Wednesday, February 11, 2009 1:50 PM
  • User1638880958 posted

    Nicely, Put I am having the same problem...

    I've been trying to figure out if this glitch was due to the CS4 download (which I highly suspect), or if it was due to an automatic update (which I doubt).  I received zero help from Adobe because my product is not supported anymore.  Other forums I've joined have not been any help either. I'm fairly sure I've narrowed it down to one of these two things though.

    An experiment in creating a new mock dynamic ASP JavaScript page renders the same error, but creating a new mock dynamic ASP VBScript page previews fine.  So I'm thinking that CS4 may have done away with ASP JavaScript and my original dll files were overwritten. 

    I have yet to overinstall MX 2004 because when I do, I'll have to reset all my settings, reapply extensions, etc.  I may just redo my dynamic pages in ASP VBScript, but.... I'm the type that fixes a problem, not ignores it, and this one really bugs me!

    I do not believe this is an IIS issue though, so we're probably in a wrong forum/wrong website altogether, but hey - you're one in a million for responding to my post, so thanks!

     

    Wednesday, February 11, 2009 2:11 PM
  • User-1217544151 posted

    Dear,

     It is not beacause of dreamweaver, it is the issue of windows authentication. please follows the instructions below:

    Control Panel < Administrative Tools < Internet Information Services < Expand USER(local Computer)  < right click on WEB SITES < Properties < Directory Security < Click Edit < and select check box of INTEGRATED WINDOWS AUTHENTICATION.

    apply the settings > Restart your computer > and check you problem is solved if not relpy

     

    Kapil 007

     

    Wednesday, February 18, 2009 1:05 AM
  • User1638880958 posted

    I'm not an IIS expert, but I can muddle through it. My setup is different - I have IIS7 on Vista. Instead of WEB SITES, it's SITES/Default Web Site.  Right-clicking does not list Properties < Directory Security < Edit.  I can manage the Default Web Site folder in one of two other ways, but the options are different from what your instructions list. So not knowing exactly where I should be, I'll explain a couple settings that may or may not be pertinent:

    Permissions have always been set to full for all users (this is a home PC). 

    Authentication lists four items: Anonymous (enabled), ASP.NET Impersonation (disabled), Basic Authentication (disabled), Forms Authentication (disabled).

    Basic Settings lists two tabs under Pass-through Authentication: "Connect as" and "Test Settings". Test Settings lists two results: Authentication and Authorization.  Authentication is fine but Authorization says "Cannot verify access to path. Details: The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again."

    The Application Pool identity is LocalSystem. The physical path is %SystemDrive%\inetpub\wwwroot.  If it's permissions that verifies the Read access, again, full permissions have been set.

    Am I close or clear out of range with your instructions? 

     

    Wednesday, February 18, 2009 2:04 PM
  • User1638880958 posted

    Well, this answers my problem in following your instructions:
    http://forums.iis.net/t/1140587.aspx
    I do have Home Premium and IIS7. 

    Still...to reiterate, I have had no problems for years previewing my dynamic pages using classic ASP JavaScript language on XP w/IIS6 or Vista w/IIS7 until very recently.  What could've changed when I haven't touched IIS?  My other computer previews pages just fine.  Same exact OS/IIS setup as my main computer.  Only difference is I downloaded that trial version of CS4 onto an external drive hooked to the main computer mid-December. Now I can't preview.

    I'm utterly stumped!

     

    Wednesday, February 18, 2009 3:11 PM
  • User1929213682 posted

    I too have similar problem. 

     I've DW CS3 installed in System with Win XP as OS (IIS 6).

    After installing DW CS4 trial version, I'm getting the following
    error in my website.

    Error Type:

    Active Server Pages, ASP 0129 (0x80004005)

    The scripting language 'jscript' is not found on the server.
    /includes/tNG/tNG.inc.asp, line 195



    The website was working fine earlier and the contents in the
    live server is working fine.

    DW CS4 has disturbed the existing one... Now I uninstalled DW CS4
    and reinstalled DW CS3 again. 

    But the problem persists....

    Help me pls..
    Tuesday, May 5, 2009 6:19 AM
  • User1638880958 posted

    After posting my problem on multiple forums and emailing Adobe support, I received very little unsuccessful suggestions or no help at all.  Adobe wouldn't even touch my question even though it pertained to their newest product -- said they didn't support my current DW version!  

    I feel that I definitely narrowed it down to a compatability conflict with CS4 trial and my current version.  I truly believe that important internal files were overwritten that my current version required.  I researched endlessly, uninstalled, reinstalled, compared IIS settings with my other computer, tweaked IIS settings, reregistered dlls, did everything I could possibly think of and read about to fix the problem.... to no avail.

    So just recently, I rebuilt my pages in ASP VBscript and all is well.  For some reason, my computer just will not accept JavaScript language anymore.  I just decided to move on.  But it really irritates me that this product (CS4) created the problem.  And it also made me want to stick with my old and outdated but trustworthy MX2004! 

     

     

    Tuesday, May 5, 2009 4:17 PM
  • User1929213682 posted

    I uninstalled DW CS4 and cleaned the registry and system  with msicuu2.exe a clean up utility got from microsoft's website and then with CS3Clean.exe another utility got from Adobe to clean and installed the DW CS3 (back to pavillion)... Removed IIS and reinstalled IIS and I'm getting the following error and trying to solve this problem.....

    Active Server Pages error 'ASP 0201'

    Invalid Default Script Language

    The default script language specified for this application is invalid.

     any help....

    Wednesday, May 6, 2009 1:51 AM
  • User1073881637 posted

    Here is a couple articles that might help with the error.

    http://classicasp.aspfaq.com/general/why-do-i-get-invalid-default-script-language-errors.html

    I would run process monitor and enable auditing to help detect any permissions error.

    http://weblogs.asp.net/steveschofield/archive/2008/03/07/detecting-permission-issues-using-auditing-and-process-monitor.aspx

    Wednesday, May 6, 2009 6:12 PM