locked
what am I doing wrong with this workflow? RRS feed

  • Question

  • I salute all the experts who help lost souls!

    I created a workflow that copies items created in a survey to a custom list (pretty simple workflow, creates an item in the custom list and then copies the current item in the custom list).

    I am wondering what I'm doing wrong! They all say 'Error Occurred" however I can see the item created in the new list... When I click the "Error Occurred" it says : The workflow could not copy the item. Make sure the source and destination lists
    have the same columns and column settings.

    I'm getting messages from the people completing the surveys worried their answers weren't saved, is there any way to fix that? I swear the workflow works!!! It's copying the item! so what's up with that error? I made sure that all the columns have the same settings...

    Thank you!

    Tuesday, September 5, 2017 7:14 PM

Answers

  • Hi mr459w,

    Are you using both “Create List Item” and “Copy List Item” actions in the workflow?

    We cannot use “Copy List Item” to copy the responses from the survey to the custom list because this custom list does not have the same columns as the survey list. The error “The workflow could not copy the item. Make sure the source and destination lists have the same columns and column settings” occurs and the response will not be copied to the custom list.

    As Asfaw Ayele mentioned, you should use the “Create List Item” and set the field values to the response values. It works.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 6, 2017 9:10 AM

All replies

  • Custom list column must exactly match Survey list fields. That's pretty obvious then workflow logic needs to be defined clearly on what triggers item move:

    1. is it on Item create? 

    2. Is it on Item changed?

    3. or survey completed?

    Once you figure that out the rest can be handled through SPDesigner workflow using action item "Create Item in..."

    Another similar thread:

    https://social.msdn.microsoft.com/Forums/en-US/c5fb6824-d09f-4d4e-bc4b-0f982ac905f6/import-the-survey-responses-to-a-separate-sharepoint-list-2010?forum=sharepointcustomizationprevious 

    Tuesday, September 5, 2017 7:58 PM
  • Hi mr459w,

    Are you using both “Create List Item” and “Copy List Item” actions in the workflow?

    We cannot use “Copy List Item” to copy the responses from the survey to the custom list because this custom list does not have the same columns as the survey list. The error “The workflow could not copy the item. Make sure the source and destination lists have the same columns and column settings” occurs and the response will not be copied to the custom list.

    As Asfaw Ayele mentioned, you should use the “Create List Item” and set the field values to the response values. It works.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 6, 2017 9:10 AM
  • Thank you!!!

    I was under the impression that the instructions I got were to create the item and then copy but I guess I misunderstood because simply doing the "Create item" step is working like a charm!

    I'm really grateful for this forum, thank you so much for helping! this saved me so much headaches!

    Best regards,

    A happy customer :)

    Wednesday, September 6, 2017 12:15 PM