locked
Windows Media Player cannot open "MS Video 1" encoded video files RRS feed

  • Question

  • Hello,

    I have encountered a problem while trying to open an .avi video file. The video file was created by means of DirectShow graph and using the video codec "Microsoft Video 1". This codec is always installed on the system by default. Therefore, I guessed that the Windows Media Player should be able to handle it.

    I get the following message box, while trying to open the file:

    "Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file."

    However, if I play this file by means of DirectShow graph again, then there is no problem to see the video data.

    Any ideas? Thanks.

    best regards,

    Vitali

    Thursday, May 3, 2012 11:44 AM

Answers

  • The reason is that the recorded video file may start with not a keyframe, but with an intermediate one. Obviously, Windows media player cannot handle such file correctly. The workaround for this is to configure the video codec in that way that every frame is a keyframe at the beginning and set back this setting after some seconds.
    • Marked as answer by vanselm Monday, January 21, 2013 3:30 PM
    Monday, January 21, 2013 3:30 PM

All replies

  • Hello,

    this Fix did not solve the issue. Another suggestions?

    best regards,

    Vitali

    Friday, May 4, 2012 7:04 AM
  • More information:

    1) I am working with Windows 7. If I select the video file, then I can see beside the file information the thumbnail image of the video. This means the system can decode one frame at least. Why does not it work with the whole file?

    2) This video file can be played by VLC player. However the color is not original.

    Friday, May 4, 2012 7:19 AM
  • The reason is that the recorded video file may start with not a keyframe, but with an intermediate one. Obviously, Windows media player cannot handle such file correctly. The workaround for this is to configure the video codec in that way that every frame is a keyframe at the beginning and set back this setting after some seconds.
    • Marked as answer by vanselm Monday, January 21, 2013 3:30 PM
    Monday, January 21, 2013 3:30 PM