locked
why the game cant run at the second time

    Question

  • i finished a metro style game, then i build it as a local package( from vs11 menu: store->create app package->local mode), and i copy the package to the target tablet, and install the package , it seems everything is ok, and i can run the game after installing. 

    then i close the game in taskmanager, but when i want to run it again, it just show a splash bitmap, after that, just leave a green screen. it doesnt show any message to me .

    then i copy the source code to the tablet, using the vs11 embeded in the tablet to see what is the problem.  but it is ok when i run it in the vs11 or i deploy it in the vs11 for many times. 

    i should do something else in creating the app package? 

    thanks a lot

    Thursday, February 09, 2012 9:31 AM

All replies

  • It sounds like you have a problem when your application is initializing.  You can use remote debugging to see if you can spot the problem:

    http://social.msdn.microsoft.com/Forums/en-US/winappswithhtml5/thread/985c9279-095a-4d43-a37d-3ba7a218d2bd

    -Jeff


    Jeff Sanders (MSFT)

    Thursday, February 09, 2012 7:04 PM
    Moderator
  • but when i copy all source code to the tablet, you known it has vs11 also, and it seems everything is ok, and i deploy it in the vs11 , it  is ok also, so i dont known what is wrong with the code, maybe it costs too long time in the initializing? 

    thanks a lot

    Friday, February 10, 2012 2:02 AM
  • Hi William,

    How long does your application take to initialize?

    -Jeff


    Jeff Sanders (MSFT)

    Friday, February 10, 2012 1:06 PM
    Moderator